Announcement

Collapse
No announcement yet.

3.8.10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TS | Julio
    replied
    Originally posted by Mark.B View Post

    We do not support that and we don't want to encourage it. People can break their installations.

    For older versions of php, 3.8.9 should be used. Or just upgrade php. Anything less than 5.5 is no longer supported by php and risks security problems.
    Yes this is understood.
    It's ok if you want to delete my posts here where this is described.
    As in my case not upgrading to 3.8.10 RC1 is out of the question since that fixes a security issue.
    But also as described by Gary Fischman doing so on an older PHP version results in a broken installation.
    In my case I can't upgrade PHP due to it being integrated with the rest of the site, which is not working on the later PHP version.
    Obviously that itself in my case is something that needs to be fixed, but not meanwhile leaving an open security vulnerability for obvious reasons!

    Leave a comment:


  • Mark.B
    replied
    Originally posted by TS | Julio View Post

    Well this is in reply to motd2's post which is about getting vB 3.8.10 modded to work on old PHP versions.
    We do not support that and we don't want to encourage it. People can break their installations.

    For older versions of php, 3.8.9 should be used. Or just upgrade php. Anything less than 5.5 is no longer supported by php and risks security problems.

    Leave a comment:


  • TS | Julio
    replied
    Originally posted by Mark.B View Post

    Please do NOT do this. 3.8.10 requires php 5.5 or above. Removing the check in the upgrade script will allow it to run but the software will not work.
    Well this is in reply to motd2's post which is about getting vB 3.8.10 modded to work on old PHP versions.

    Leave a comment:


  • Mark.B
    replied
    Originally posted by TS | Julio View Post
    Note that to successfully run the upgrade script itself on an older PHP version you must also edit install/upgradecore.php line 425:
    Code:
    if (version_compare(PHP_VERSION, '5.5.0', '<'))
    Otherwise you will just get this message:
    This version of vBulletin requires PHP version 5.5.0 or greater. Your PHP is version 5.3.29, please ask your host to upgrade.
    Please do NOT do this. 3.8.10 requires php 5.5 or above. Removing the check in the upgrade script will allow it to run but the software will not work.

    Leave a comment:


  • TS | Julio
    replied
    Note that to successfully run the upgrade script itself on an older PHP version you must also edit install/upgradecore.php line 425:
    Code:
    if (version_compare(PHP_VERSION, '5.5.0', '<'))
    Otherwise you will just get this message:
    This version of vBulletin requires PHP version 5.5.0 or greater. Your PHP is version 5.3.29, please ask your host to upgrade.

    Leave a comment:


  • motd2
    replied
    Originally posted by Gary Fischman View Post

    Are you effin' kidding me?
    mmm.... here http://www.vbulletin.com/forum/forum...ulletin-3-8-10


    Take from the previous version at your own risk))
    line 689-697
    Code:
            if (empty($postvars_encoded = json_encode($_POST)))
            {
                // Try converting to utf8 - the //TRANSLIT tells it to guess at any failed characters
                if (empty($postvars_encoded = json_encode(iconv(vB_Template_Runtime::fetchStyleVar('charset'), 'UTF-8//TRANSLIT', $postvars))))
                {
                    // It still failed, give up
                    eval(standard_error(fetch_error('error_500_description', $vbulletin->options['bburl'], $vbulletin->session->vars['sessionurl'], vB::$vbulletin->options['contactuslink'])));
                }
            }
    replace
    Code:
            $string = json_encode($_POST);

    Leave a comment:


  • Gary Fischman
    replied
    Originally posted by motd2 View Post

    Need php 5.5 or 5.6
    Are you effin' kidding me? I just finished a major upgrade to get PHP 5.4 working so I could install Beta 1. Beta 1 works fine under 5.4. Why can't the 1 or 2 lines that are causing this bug under 5.4 simply be rewritten so I'm not forced to do another majorly disruptive upgrade?

    Meanwhile, I'd still like to know how to report this bug.

    Leave a comment:


  • motd2
    replied
    Originally posted by Gary Fischman View Post

    How do I report a bug in the Beta2 upgrade.php?
    Need php 5.5 or 5.6

    Leave a comment:


  • Gary Fischman
    replied
    Originally posted by Mark.B View Post
    To upgrade from Beta 1 to Beta 2 you DO need to run the upgrade script. There is no patch for the beta versions.
    How do I report a bug in the Beta2 upgrade.php?

    Parse error: syntax error, unexpected '=', expecting ')' in /xxx/xxx/xxx/vb3.8.10.b2/upload/includes/functions_misc.php on line 689

    Leave a comment:


  • Mark.B
    replied
    To upgrade from Beta 1 to Beta 2 you DO need to run the upgrade script. There is no patch for the beta versions.

    Leave a comment:


  • IggyP
    replied
    if im not mistaken you only need to overwrite the files not run the script so pretty painless

    Leave a comment:


  • Gary Fischman
    replied
    OK, so a few weeks ago, I installed 3.8.10 Beta 1, and now I see there's a Beta 2 due to a security issue where you created patches for older versions. Can we get a patch for 3.8.10 Beta 2 from Beta 1? I really don't want to have to do a complete install yet again.

    Thanks in advance!

    Leave a comment:


  • Mark.B
    replied
    No, we don't provide patch releases in place of full upgrades and never have. If it could be done with a patch, we would release one. There are far too many changes.

    Leave a comment:


  • Gary Fischman
    replied
    Is it possible to get a patch release of this? I'm terrified of having to upload everything and wipe out all the hacks that have accumulated over the years.

    Leave a comment:


  • Mark.B
    replied
    It is available in the members area, same place as all other versions. It will be in the version dropdown.

    Leave a comment:

Related Topics

Collapse

Working...
X