Announcement

Collapse
No announcement yet.

3.8.10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.8.10

    I see 3.8.10 beta in the member area, but I can't find any release notes for it.
    Are there release notes available?
    Will there be a GA release of this at some point?
    Will 3.8.10 work with PHP 5.3.3?

    My understanding is this release addresses the IPN changes being made by PayPal.

    Thanks in advance.

  • #2
    This link should show you what's in 3.1.10 Beta 1:
    3.8.10 Beta 1

    The PayPal IPN changes are covered by this:
    http://tracker.vbulletin.com/browse/VBIII-12998

    There will be a full release at some point but it's fine to use the current vB3 and vB4 betas (but not vB5 betas) on production systems.

    The official minimum version of php for all branches of vBulletin is now 5.4. With vB3, you might find php 5.3 works but if it doesn't there's nothing we can do.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      What is the link to get the Beta?

      BTW - I've been registered here for many years so I'm really not a "new" member. Just haven't been here in a while. vB user since around 2002. Not sure why the box on the left is showing me as having registered in 2014. Running vB 3.8.9 since last year.
      Last edited by Elsmarc; Wed 11th May '16, 2:24am. Reason: Add info/comment about "Join Date"

      Comment


      • #4
        It is available in the members area, same place as all other versions. It will be in the version dropdown.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.6 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Is it possible to get a patch release of this? I'm terrified of having to upload everything and wipe out all the hacks that have accumulated over the years.

          Comment


          • #6
            No, we don't provide patch releases in place of full upgrades and never have. If it could be done with a patch, we would release one. There are far too many changes.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.6 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              OK, so a few weeks ago, I installed 3.8.10 Beta 1, and now I see there's a Beta 2 due to a security issue where you created patches for older versions. Can we get a patch for 3.8.10 Beta 2 from Beta 1? I really don't want to have to do a complete install yet again.

              Thanks in advance!

              Comment


              • #8
                if im not mistaken you only need to overwrite the files not run the script so pretty painless

                Comment


                • #9
                  To upgrade from Beta 1 to Beta 2 you DO need to run the upgrade script. There is no patch for the beta versions.
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.5.6 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    Originally posted by Mark.B View Post
                    To upgrade from Beta 1 to Beta 2 you DO need to run the upgrade script. There is no patch for the beta versions.
                    How do I report a bug in the Beta2 upgrade.php?

                    Parse error: syntax error, unexpected '=', expecting ')' in /xxx/xxx/xxx/vb3.8.10.b2/upload/includes/functions_misc.php on line 689

                    Comment


                    • #11
                      Originally posted by Gary Fischman View Post

                      How do I report a bug in the Beta2 upgrade.php?
                      Need php 5.5 or 5.6

                      Comment


                      • #12
                        Originally posted by motd2 View Post

                        Need php 5.5 or 5.6
                        Are you effin' kidding me? I just finished a major upgrade to get PHP 5.4 working so I could install Beta 1. Beta 1 works fine under 5.4. Why can't the 1 or 2 lines that are causing this bug under 5.4 simply be rewritten so I'm not forced to do another majorly disruptive upgrade?

                        Meanwhile, I'd still like to know how to report this bug.

                        Comment


                        • #13
                          Originally posted by Gary Fischman View Post

                          Are you effin' kidding me?
                          mmm.... here http://www.vbulletin.com/forum/forum...ulletin-3-8-10


                          Take from the previous version at your own risk))
                          line 689-697
                          Code:
                                  if (empty($postvars_encoded = json_encode($_POST)))
                                  {
                                      // Try converting to utf8 - the //TRANSLIT tells it to guess at any failed characters
                                      if (empty($postvars_encoded = json_encode(iconv(vB_Template_Runtime::fetchStyleVar('charset'), 'UTF-8//TRANSLIT', $postvars))))
                                      {
                                          // It still failed, give up
                                          eval(standard_error(fetch_error('error_500_description', $vbulletin->options['bburl'], $vbulletin->session->vars['sessionurl'], vB::$vbulletin->options['contactuslink'])));
                                      }
                                  }
                          replace
                          Code:
                                  $string = json_encode($_POST);

                          Comment


                          • #14
                            Note that to successfully run the upgrade script itself on an older PHP version you must also edit install/upgradecore.php line 425:
                            Code:
                            if (version_compare(PHP_VERSION, '5.5.0', '<'))
                            Otherwise you will just get this message:
                            This version of vBulletin requires PHP version 5.5.0 or greater. Your PHP is version 5.3.29, please ask your host to upgrade.
                            Julio Franco
                            TechSpot.com

                            Comment


                            • #15
                              Originally posted by TS | Julio View Post
                              Note that to successfully run the upgrade script itself on an older PHP version you must also edit install/upgradecore.php line 425:
                              Code:
                              if (version_compare(PHP_VERSION, '5.5.0', '<'))
                              Otherwise you will just get this message:
                              This version of vBulletin requires PHP version 5.5.0 or greater. Your PHP is version 5.3.29, please ask your host to upgrade.
                              Please do NOT do this. 3.8.10 requires php 5.5 or above. Removing the check in the upgrade script will allow it to run but the software will not work.
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.5.6 Demo
                              AdminAmmo - My Cloud Demo

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X