Announcement

Collapse
No announcement yet.

UTF-8 - How to maintain the same language, moving to a new host or installing new mods?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UTF-8 - How to maintain the same language, moving to a new host or installing new mods?

    Hello and Hi, Finally I made the Upgrade from vB3.8 to vB4.2! I had lots of broblems because of the Mix Languages & Collations.. But fixed it..... Now my forum is working, but after Checking my MYSQL tables, there are many vB4.2 Tables that are missing!

    Is it normal? My MYSQL tables right now after the upgrade are arround 170, while a full vB4.2 has arround 193, Why is all of the other vB4 tables missing..

    Some of the vB4.2 missing tables are:
    forumRunner
    skimlinks
    stylevar
    stylevardfn
    searchcore_text
    searchgroup
    searchgroup_text
    picturelegacy

    And for this I have 2 questions,,,

    1: Why is it missing and how come the board is working without problems,, And is there anyway to run another upgrade to get all of the original vB4.2 tables?

    2: And what can I do in future to maintain my vbulletin language as UTF_general_ci?

    Hopefully I could get some understanding help on this! Feel kinda confused!

    Thank you very much in advance, Regards CM!
    Last edited by ChiNa; Fri 26 Oct '12, 12:36pm.
    Check some of my work on vBulletin.org by CLICKING HERE!
    I dedicate my work and passion to those who have helped me and made me become the person I am today! From Coders, Designers to amazing Websites and Forums who always been there for me! Forever Greatfull!

  • #2
    Upgrading should not cause any missing tables or loss of any other data. If I were you I would revert to the backup and then re-run the upgrader once again.

    P.s. You say that your forum is working fine but if the tables were missing you should have had db errors all over the place and not a working forum. I have not used vb 3.8x so I am not familiar with its db structure but maybe those tables were removed/renamed in the 4.2x version as a designed behavior.

    Comment


    • #3
      Originally posted by borbole View Post
      Upgrading should not cause any missing tables or loss of any other data. If I were you I would revert to the backup and then re-run the upgrader once again.

      P.s. You say that your forum is working fine but if the tables were missing you should have had db errors all over the place and not a working forum. I have not used vb 3.8x so I am not familiar with its db structure but maybe those tables were removed/renamed in the 4.2x version as a designed behavior.
      @borbole sorry mate I didnt recognis you first... You are the great coder on vB.org ! You are one of my favorit coders between 2 or 3 others..

      Wow mate, What a great explanation! I think also because of the design of vBulletin structure as you said! I will try give it a shot and run the re-upgrade! BTW, about the re-upgrade should I simply run "upgrade.php" again? ! I will do that surely! I am very appreciated for your help, and thank you for all your replies on my threads! God bless you !
      Last edited by ChiNa; Fri 26 Oct '12, 11:39am.
      Check some of my work on vBulletin.org by CLICKING HERE!
      I dedicate my work and passion to those who have helped me and made me become the person I am today! From Coders, Designers to amazing Websites and Forums who always been there for me! Forever Greatfull!

      Comment


      • #4
        Originally posted by ChiNa-Man View Post
        @borbole sorry mate I didnt recognis you first... You are the great coder on vB.org ! You are one of my favorit coders between 2 or 3 others..

        Wow mate, What a great explanation! I think also because of the design of vBulletin structure as you said! I will try give it a shot and run the re-upgrade! BTW, about the re-upgrade should I simply run "upgrade.php" again? ! I will do that surely! I am very appreciated for your help, and thank you for all your replies on my threads! God bless you !
        If that is the designed behavior then you do not need to re-run the upgrader.

        But if you want to re-run the upgrade, then yes, run upgrade.php again.

        Comment


        • #5
          Originally posted by borbole View Post
          If that is the designed behavior then you do not need to re-run the upgrader.
          But if you want to re-run the upgrade, then yes, run upgrade.php again.
          I just deleted a long comment! Thank you very much Sir! I think the forum might be complete! you made an great comment! I might wait a bit and check the forum! Sir if you could help me to check my forum, I would be appreciated! As you are a coder and used a vB4.x! You know a lot better than me!

          I would be very happy If I could take some of your preciouse time! Only when you can! I will post you an admin login when ever! Thank you very much for your help sir!
          Last edited by ChiNa; Fri 26 Oct '12, 12:36pm.
          Check some of my work on vBulletin.org by CLICKING HERE!
          I dedicate my work and passion to those who have helped me and made me become the person I am today! From Coders, Designers to amazing Websites and Forums who always been there for me! Forever Greatfull!

          Comment

          Related Topics

          Collapse

          Working...
          X