Announcement

Collapse
No announcement yet.

Setting Up a Test Site - Config File Confusion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting Up a Test Site - Config File Confusion

    I'm setting up a test site to do a dry run on an upgrade.... I have done this with other forums products without issue.

    - I have setup a second hosting account http://test.mysite.com (my normal site is www.mysite.com)
    - I copied my site over to the new domain
    - I copied the database over to the new domain
    - I updated the /includes/config.php on the test site to include the details on the test database
    Everything works fine....

    Except, when I go into the admin panel of either site and close the board, both boards end up getting closed.
    Any ideas as to why the sites continue to be inter-connected?

  • #2
    In your vBulletin Options for each board make sure the forum URLs in Site Name / URL / Contact Details are unique, for example:
    Live Board: http://domain.com/forum
    Test Board: http://domain.com/vbtest

    Also Cookies and HTTP Header Options, in Path to Save Cookies:
    Live Board: /
    Test Board: /vbtest/

    And make the cookie prefix in config.php different for each board as well (but they should match what you have in Cookies and HTTP Header Options)
    ~ Life isn't always fair, but you can be. ~

    Comment


    • #3
      Thanks for your help.

      I have everything setup like that, with the exception that instead of running in a directory like /vbtest I have them at 2 different hosting accounts (on the same server). Still has me stumped though, it's the weirdest thing.

      I didn't set this board up, but was going to do an upgrade (hence the test site). Is it possible to run the config file elsewhere? I had wondered if someone hardcoded a path to the config file somewhere, which would explain why both sites seem to control each other, although I've looked and not been able to locate another config file, nor anyplace in the scripting. Hrm......

      Comment


      • #4
        Any caching running?
        My Live vB5 Site - NZEating.com
        vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

        Comment


        • #5
          Originally posted by joshpet View Post
          I had wondered if someone hardcoded a path to the config file somewhere, which would explain why both sites seem to control each other, although I've looked and not been able to locate another config file, nor anyplace in the scripting. Hrm......
          They have the same database that's why they control each other.
          Upload a freshly edited config.php file to the testforum.


          vB5 is unequivocally the best forum software, but not yet...

          Comment


          • #6
            As beishe8 said, you need to edit the Config.php files to point to the correct database. If you are using the Config file from your main board, in the test site, you will mess it up, and confuse it.

            Code:
            //	****** DATABASE NAME ******
            	//	This is the name of the database where your vBulletin will be located.
            	//	This must be created by your webhost.
            $config['Database']['dbname'] = '[COLOR="#FF0000"]yoursite_testvb[/COLOR]';

            Comment


            • #7
              - I updated the /includes/config.php on the test site to include the details on the test database
              That would suggest the assumptions given in the past 2 posts to be incorrect, if it is true.
              My Live vB5 Site - NZEating.com
              vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

              Comment


              • #8
                Thanks for the suggestions.
                Yes, I did update the config file for the test site. And for giggles to make sure that was the config.php file it was reading, I tried putting the wrong info in there and it broke, so I know it's reading that.
                We moved the test site to a totally different domain name, to try to rule out any cookie issues. Still no go.

                I looked through all the settings and didn't see anything about caching that had any file paths in it.

                Still the weirdest thing, if I close the test site, the live site also closes and the site name's/paths etc... all change. To fix it you have to go back and reopen it from the live site and that fixes the site name etc... But it's like they are both open or both closed.

                We're doing the test site to do a trial run on an upgrade, and I don't want to try the upgrade until I'm sure I'm not messing with the live site.

                If it were a caching thing, where would I look to resolve that. I read about options being stored in the datastore table, could that be the issue?

                Comment


                • #9
                  You need to update the bburl value in both the settings and datastore tables to ensure that the test site looks to the correct URL
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - "Quick Route" Interface...

                  Comment


                  • #10
                    Thanks everyone for your help. We got it solved. We were using Memcached and once we disabled that on the test site, things started behaving properly!

                    Comment


                    • #11
                      Originally posted by Ace View Post
                      Any caching running?
                      Originally posted by joshpet View Post
                      Thanks everyone for your help. We got it solved. We were using Memcached and once we disabled that on the test site, things started behaving properly!
                      Hurrah!
                      My Live vB5 Site - NZEating.com
                      vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X