Announcement

Collapse
No announcement yet.

3.8.7 PL4 upgrade errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BirdOPrey5
    replied
    Hello,

    VB 3.8,7 is not compatible with PHP 5.4.x. You will need to use VB 3.8.8 Beta 4 to use PHP 5.4.x. You can downgrade PHP but only to PHP 5.2.x or PHP 5.3.x, the latest patch makes the minimum PHP version 5.2.0.

    If you absolutely cannot use VB 3.8.8 beta and cannot get PHP 5.2.x or PHP 5.3.x see the patch announcement thread there is an option to manually install the JSON functions on older versions of PHP to make the patch compatible with older versions but this would be a last resort option.

    Leave a comment:


  • Robert Fogt
    replied
    I should note I have access to PHP version 4 or version 5.4

    I have tried editing every file and commenting out @ini_set('display_errors', true); but the errors continue.

    Leave a comment:


  • Robert Fogt
    started a topic 3.8.7 PL4 upgrade errors

    3.8.7 PL4 upgrade errors

    I am upgrading from 3.8.4 to 3.8.7 PL4, after uploading all files the board is not displaying errors, but upgrade is. The only reason I was upgrading was because of the security flaw.

    I am getting the following errors running /install/upgrade.php script

    Strict Standards: Non-static method vB_Shutdown::init() should not be called statically, assuming $this from incompatible context in /htdocs/ocforum/includes/class_core.php on line 2555

    Strict Standards: Non-static method vB_Bitfield_Builder::build_datastore() should not be called statically in /htdocs/ocforum/install/init.php on line 189

    Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically in /htdocs/ocforum/includes/class_bitfield_builder.php on line 227

    Strict Standards: Non-static method vB_Bitfield_Builder::build() should not be called statically in /htdocs/ocforum/includes/class_bitfield_builder.php on line 233

    Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically in /htdocs/ocforum/includes/class_bitfield_builder.php on line 89

    Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically in /htdocs/ocforum/install/init.php on line 191

    Strict Standards: Non-static method vBulletinHook::init() should not be called statically in /htdocs/ocforum/install/init.php on line 212

    Strict Standards: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /htdocs/ocforum/install/upgrade_language_en.php on line 199

    Strict Standards: Non-static method vBulletinHook::fetch_hook() should not be called statically in /htdocs/ocforum/includes/functions.php on line 3151

    Strict Standards: Non-static method vBulletinHook::init() should not be called statically in /htdocs/ocforum/includes/class_hook.php on line 118

    Warning: Cannot modify header information - headers already sent by (output started at /htdocs/ocforum/includes/class_core.php:2555) in /htdocs/ocforum/includes/functions.php on line 3161

Related Topics

Collapse

Working...
X