Announcement

Collapse
No announcement yet.

The upgrade instructions don't make sense!?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The upgrade instructions don't make sense!?

    Hi,

    I've just bought the vb5 license so that I can upgrade to vb3.8.8. Here are the upgrade instructions that come with it:


    Upgrading from a previous version of vBulletin 3

    Close your board via the Admin Control Panel.
    Upload all files from the 'upload/' folder in the zip, with the exception of 'install/install.php'. Then open the 'upload/includes/' folder. In this you will find config.php.new. You should rename this to config.php and then open it in a text editor.
    Open your browser and point the URL to http://<span style="color:red">www.e.../forum/</span>install/upgrade.php (where www.example.com/forums/ is the URL of your vBulletin). You should now be automatically forwarded to the appropriate upgrade script and step.
    Follow the instructions on the screen. Make sure you click next step or proceed until you are redirected to your Admin Control Panel. Here, you can reopen your board.
    For a complete description of how to upgrade from a previous version of vBulletin 3 to the latest version, see the upgrade section of the vBulletin 3 Manual.
    Please note that the format for config.php in vBulletin 3.5.x is different from previous versions of vBulletin, and you will need to manually update your config file to the new format. Instructions are here.

    --

    Bit that doesn't make sense to me is:

    Then open the 'upload/includes/' folder. In this you will find config.php.new. You should rename this to config.php and then open it in a text editor.

    --

    What do you do with it once you've opened it!? Do you open the local copy or the uploaded one?


    I tried uploading it and then renaming it to config.php but just a database error.

    I went through the upgrade process on my test board without doing anything to the existing config.php and all seemed fine.

    Can anyone tell me what I'm supposed to do with config.php.new please?

    Thanks,
    Andy F


  • #2
    (Edit: Sorry, wrong topic.)

    Comment


    • #3
      Can no one on here tell me what I should do with the config.php in the upgrade?

      Comment


      • #4
        Hello

        If you are only going to 3.8.8 then don't worry about the config file...your existing one will be fine.
        You can delete config.php.new and just stick with the existing config.php.
        Just upload all the files, run install/upgrade.php, then delete the /install folder when the upgrade is complete.

        Make sure you have a backup of files and database before running any upgrade.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.3 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Also suggest reading the upgrade instructions in the online manual for vBulletin 3.8.7 (identical to 3.8.8) - http://www.vbulletin.com/docs/html/u...rsion=30807603

          Comment


          • #6
            Many thanks Mark, and Joe.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X