Announcement

Collapse
No announcement yet.

Upgrading from 3.6.7 to 3.8, problem on one of the steps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Paul M View Post
    This is not a bug.
    I respectfully disagree. On the one hand, for myself, and the other posters here, the upgrade didn't work. With this fix it does. Also, the behaviour is contrary to your statements "The installer checks the mysql version and uses TYPE if its older than 4.0.18, or ENGINE otherwise.". I understand you're not a developer, so allow me to explain this.

    'TYPE' was used for mySQL versions below 4.0.18
    'ENGINE' is used for mySQL versions 4.0.18 and above.

    The text that shipped with vBulletin was 'TYPE', which means that it doesn't support mySQL with versions above 4.0.18

    Looking through the rest of the code, I can see that when moving from an older version of vb, to a newer version, code was included that did essentially exactly what I have done. The code I used was taken from elsewhere in the vb codebase.

    I am saying this is a bug, because the change was missed in this location. I suggest if you took the time to check with a vBulletin developer, they would agree.

    Originally posted by Paul M View Post
    The minimum supported MySQL version for vB4 is 4.1.0, therefore no check is needed (4.1 onwards supports ENGINE).
    I know. I'm running mySQL 5.1.15, and I got this error. The issue may only manifest itself when upgrading from vB 3.8.
    In fact the issue is not a 'minimum supported version' but a 'maximum supported version', because the syntax changed between mySQL versions.

    Originally posted by Paul M View Post
    JFYI, vBulletin support are not developers.
    Yes I'm aware of that. However, I don't have a direct line to the vBulletin development team, and I rely on support personnel to pass on this sort of information. If you'd like me to raise a bug report I can do that too.

    Perhaps if people like me keep insisting that we get some value out of the license fees we pay, then we won't be dismissed so readily.

    Comment


    • #17
      AlphaSoftware, and anyone else who has this issue, I have attached the corrected version of class_dbalter.php. It lives here:
      ./includes/class_dbalter.php

      This is for the 4.1.5 version of vBulletin, but if you're upgrading to a different version, then you'll need to make the changes manually.
      Last edited by Paul M; Tue 6 Sep '11, 5:20am. Reason: Full files are not permitted to be uploaded, as per the licence.

      Comment


      • #18
        Originally posted by Jimbot View Post
        I respectfully disagree.

        'TYPE' was used for mySQL versions below 4.0.18
        'ENGINE' is used for mySQL versions 4.0.18 and above.

        I am saying this is a bug, because the change was missed in this location. I suggest if you took the time to check with a vBulletin developer, they would agree.
        You are free to disagree.

        I should have been a little more accurate to avoid confusion.

        This is not a bug in v 4.1.5 onwards (i.e. in the latest release).

        class_dbalter.php was updated in 4.1.5 to use ENGINE, not TYPE.

        It does not need a check since ENGINE will (as stated) work in any mysql version 4.0.18 and above, and the minimum for vb4 is 4.1
        Baby, I was born this way

        Comment


        • #19
          Originally posted by Paul M View Post

          This is not a bug in v 4.1.5 onwards (i.e. in the latest release).

          class_dbalter.php was updated in 4.1.5 to use ENGINE, not TYPE.
          While that's good to know, the issue occurs during an upgrade from 3.6.7 to 3.8, as the OP described. I believe it is still recommended practice for vBulletin users on a lesser 3.x version to upgrade to 3.8 before upgrading to the latest 4.x. Because of this, users wishing to upgrade from 3.6.7 (or any other earlier version) to 3.8 WILL STILL ENCOUNTER THIS BUG. Is it possible to fix the code in 3.8 as I have described? This would not need to be anything more than a patch release, and it would allow users on 3.6.7 and earlier to upgrade all the way through to 4.1.5.
          Last edited by Jimbot; Tue 6 Sep '11, 3:46pm.

          Comment


          • #20
            I dont know where that recomendation comes from, but its not necessary - the 4.1.5 installer will directly upgrade any forum version from 3.5.4 onwards [all the way to 4.1.5]. One of my databases that I test upgrades with is 3.5.8.
            Baby, I was born this way

            Comment


            • #21
              Hi Paul, are you certain that this is not a bug in vB? Because I am having exact same problem and didn't know about this thread. I just created a new thread: http://bit.ly/qE0Y4a

              Comment


              • #22
                Three posts up.

                class_dbalter.php was updated in 4.1.5 to use ENGINE, not TYPE.
                Baby, I was born this way

                Comment


                • #23
                  Thanks Paul

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X