Announcement

Collapse
No announcement yet.

SQL Error - Specified Key was too long

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL Error - Specified Key was too long

    I'm trying to install vBulletin on my C: Drive usin xampp, I've never had any problems doing this before but now when I try to do it I recieve this error...

    Code:
    Database error in vBulletin :
    
    Invalid SQL:
    
    CREATE TABLE vb3_bbcode (
        bbcodeid SMALLINT UNSIGNED NOT NULL AUTO_INCREMENT,
        bbcodetag VARCHAR(200) NOT NULL DEFAULT '',
        bbcodereplacement MEDIUMTEXT,
        bbcodeexample VARCHAR(200) NOT NULL DEFAULT '',
        bbcodeexplanation MEDIUMTEXT,
        twoparams SMALLINT NOT NULL DEFAULT '0',
        title VARCHAR(100) NOT NULL DEFAULT '',
        buttonimage VARCHAR(250) NOT NULL DEFAULT '',
        options INT UNSIGNED NOT NULL DEFAULT '1',
        PRIMARY KEY (bbcodeid),
        UNIQUE KEY uniquetag (bbcodetag, twoparams)
    );
    
    MySQL Error   : Specified key was too long; max key length is 767 bytes
    Error Number  : 1071
    Request Date  : Tuesday, February 8th 2011 @ 03:01:41 PM
    Error Date    : Tuesday, February 8th 2011 @ 03:01:42 PM
    Script        : http://localhost/vb/install/install.php?step=3
    Referrer      : http://localhost/vb/install/install.php?step=2
    IP Address    : *******
    Username      : 
    Classname     : vB_Database
    MySQL Version : 5.5.8
    Any help would be appreciated.

    Thanks

  • #2
    It looks like the bbcode tag is too long which is very odd for a fresh install. Which version of MySQL is this?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol View Post
      It looks like the bbcode tag is too long which is very odd for a fresh install. Which version of MySQL is this?
      It's 5.5.8.

      Comment


      • #4
        Kane, can you edit the my.ini file and adjust mysql's operation to disable innodb?

        Use something like this to disable innodb:
        http://geekydesigns.com/my.txt

        The bit about skipping innodb is important. Then try to reinstall

        After you change this, restart mysql.

        Comment


        • #5
          Thanks, Zachery but I've just done that and I'm still getting the same error.

          Comment


          • #6
            The EXACT same error? Can you please post it?

            Comment


            • #7
              *EDIT* - Yes it is the exact same error.

              Comment


              • #8
                Are you sure you made the change and restarted mysql?

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X