Announcement

Collapse
No announcement yet.

Uploaad of File Failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Uploaad of File Failed

    Getting Upload of File Failed - for users who have permission to post images.

    On IIS - own the server - upgraded install about a month ago to 3.8.5 from previous version. File uploading always worked prior - so it's not a file size issue etc. Suddenly getting Upload of File Failed. Test files were jpg's under 20k.

    Running the test under maint., I got...

    Help Pertinent PHP Settings
    file_uploads: On
    open_basedir: None
    safe_mode: Off
    upload_tmp_dir: C:\WINDOWS\Temp
    upload_max_filesize: 2.00 MB

    Help Results
    No errors occurred while opening the uploaded file for reading.

    Kind of stuck - not sure what to check. I believe at the same time I upgraded VB, I also upgraded php and mysql to the latest in their respective lines to patch security issues - but settings usually don't change when that happens.

    Appreciate if you have any ideas.

  • #2
    Have you checked the size limit allowed in vBulletin for that type of attachment, like JPG, GIF, ZIP e.t.c. In the attachment settings in your Admin CP?

    Comment


    • #3
      Yep - files were well under the size limit and this used to work prior to upgrade.


      bmp 20000 620 280
      gif 20000 620 280
      jpe 20000 620 280
      jpeg 20000 620 280
      jpg 100000 none none

      Just tried a 6k test file and I'm the admin/owner...

      test.jpg:
      Upload of file failed.
      Last edited by Levelbest; Tue 1st Jun '10, 11:42am.

      Comment


      • #4
        What about the image dimensions though?

        620x280 is very small in (height), because of that "280px" bit. It should be changed to something like: 1024x768, 800x600 or 640x480 e.t.c. All depends on you? And of course the image you upload should be within both the file-size allowed and the image-dimensions you set-up.

        Comment


        • #5
          The file was 150x150.

          We only use JPG's for larger files. It doesn't work for any size jpg despite the fact the size isn't even constrained.

          Just tried the same file as a gif - 11k - 150x150px - no go.

          Something was clearly reset during the upgrade - but I can't figure out what and the test thru the CP doesn't give me any hints... it makes it look like things are just fine.

          Comment


          • #6
            Ah right, so it was within the image size limit then, have you tried setting a larger image file size allow just be 100% sure, maybe bump it up from: 20000 to 200000 (add an extra 0) just to test.

            To be honest when I used vB 3.6 I did notice myself that for some odd reason, I could still upload an image larger than 640x480 (which was the maximum image size I allowed for all types). Not sure why I could do that back then. Unless it takes one or the other to allow it?

            Comment


            • #7
              Hmmm - believe I finally figured it out.

              I gave r/w/d permissions to IUSR on the temp directory - and it appeared to work. Posting here for anyone else who runs IIS. Not sure what changed or when but it was working a month or so ago. Is it possible the vbulletin upgrade moved the location that temp files were written to between say 3.6 and 3.8?

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X