Announcement

Collapse
No announcement yet.

Forum Upgrade from 3.8.1 PL1 to 3.8.4 PL1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DirtyHarry
    replied
    You are welcome

    Leave a comment:


  • Welshy
    replied
    Thank You Harry,


    It was a "Pre-Fix" problem - I had, Indeed set it the same as the Test forum that I deleted.



    Thank You very much, Once again for your valuable input.


    Forum is now working again.

    Leave a comment:


  • DirtyHarry
    replied
    Hello,

    the only way I can see this happening is that you are still connecting to your test forum DB. Triple check the DB information in your config.php. What is your forum URL?

    Leave a comment:


  • Welshy
    replied
    This has definately got something to do with the vB 3.8.4 PL1 Functions.php Getting mixed with the vB4 Beta 4 that I had on my Test Forum.


    Question is - is there a way that I can overcome it?

    Leave a comment:


  • Welshy
    replied
    With respect to my above post...

    ... I have tried re-uploading the Functions.php file, But it is still the same.

    Leave a comment:


  • Welshy
    replied
    Tried to upgrade approx 02.00 GMT and Have been trying 'til now with no success. I have the following showing and No forum:

    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/*****/public_html/forum/includes/functions.php(5347) : eval()'d code on line 1

    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/*****/public_html/forum/includes/functions.php(5430) : eval()'d code on line 1

    Parse error: syntax error, unexpected T_STRING in /home/*****/public_html/forum/global.php(603) : eval()'d code on line 1

    Fatal error: Class 'vB_Template_Runtime' not found in /home/*****/public_html/forum/global.php(604) : eval()'d code on line 6

    and when I try to log into my ACP I get:

    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/******/public_html/forum/includes/functions.php(5347) : eval()'d code on line 1

    Parse error: syntax error, unexpected T_STRING in /home/******/public_html/forum/global.php(603) : eval()'d code on line 1

    Fatal error: Class 'vB_Template_Runtime' not found in /home/******/public_html/forum/global.php(604) : eval()'d code on line 6

    Even though I uploaded (to upgrade) 3.8.4 pl1 - for some reason it is showing vBulletin 4.0.0 Beta 4 - and my Test forum name - (Where I log in to my ACP) and on the top of the forum page (Before I tried to revert back to the way the forum was before, by using my Backup) - it isn't showing my Proper forum (live). I have since deleted the folder containing the Test site, but it is still showing my Test forum name on the AdminCP.


    Any Ideas as to how I sort this out please?

    Leave a comment:


  • Welshy
    replied
    Thank You Trevster.


    Appreciated.

    Leave a comment:


  • Trevor Hannant
    replied
    Styles are actually held in the Database so you won't see anything style related in the folders.

    It's possible he's deleted the test installation as it wasn't actually required anymore. Looking at the updates made for 3.8.2, 3.8.3 and 3.8.4, you shouldn't have any issues with upgrading it unless you've done some heavy customisation of your templates, in particular those pertaining to Social Groups. You should be fine to go ahead and upgrade although make sure you take a backup of your database and files before carrying out the upgrade.

    Leave a comment:


  • Welshy
    replied
    I have just checked and there are no files/folders in my forum route, that I can see, that belong the 'Forum Default Style' which the coder added (on top of the name of my Live forum).


    How on earth did he do it and where could he have put it.


    Yes I know, Only he will know. But I have forgotten who did it and I weren't 100% happy.

    Leave a comment:


  • Welshy
    replied
    Thank You Trevster,

    The problem that I have is that I haven't a clue where the coder that did them for me, has put the 'Test Forum' folder or what he has named it.


    I shall have another scout around for it.

    Many Thanks.

    Leave a comment:


  • Trevor Hannant
    replied
    Only the files you upload will be overwritten. Anything else will remain there.

    Firstly, upgrade your test forum and make notes about anything you feel you will need to remember. To upgrade (once you've backed up your database):

    - Close your test forum via AdminCP > vBulletin Options > Turn Your vBulletin On and Off
    - upload the files
    - open your browser and go to yoursite.com/(test forum directory)/install/upgrade.php
    - enter your customer number
    - follow the prompts

    Once that's done, have a look through your test forum, make a post or two, edit etc just to make sure YOU are hapy with the upgrade then go back into AdminCP > vBulletin Options > Turn Your vBulletin On and Off and re-open your test forum.

    Once you're happy that you can do this, folow the above step again but doing this for your live forum

    Leave a comment:


  • Welshy
    replied
    Would someone also comfirm that, And I am sorry if that sounds like basic stuff...

    ... I have renamed the "Upload Folder" to that of my forum...

    ... This will naturally be "Overwitten". But can you confirm that it will not take the place of the complete original forum folder? The reason is that I have other items within that folder too.


    Many Thanks.

    Leave a comment:


  • Welshy
    started a topic Forum Upgrade from 3.8.1 PL1 to 3.8.4 PL1

    Forum Upgrade from 3.8.1 PL1 to 3.8.4 PL1

    HI Guys,

    I have always paid someone to do the upgrades for me.

    I can no longer afford to do this, so I will have to do it myself.

    The last person to upgrade the forum for me, Put a "Test forum" and a "Live forum" on there for me, I would chose between the two (to view) from the drop down menu.

    How would I be able to change the both of them please?

    There are areas of the Live forum that I do not want changed (ie Smilies) so I have removed that foilder so that it doesn't overwrite my custom smilies. That's right, Isn't it?

    I would then need to do an upgrade on the test forum, Yes? with All the files, None removed for this, Correct?

    How exactly, in Laymans terms, would I do that please?


    Many Thanks.


    PS. I will be backing up the forum database BEFORE doing anything.

Related Topics

Collapse

Working...
X