Announcement

Collapse
No announcement yet.

Database Error While Upgrading

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database Error While Upgrading

    Hi there,

    I did some reading before I posted... but I really couldn't find an answer that seemed to work.

    Today I upgraded (my first time doing so) to 3.8.4 (I had 3.8.3). I followed the directions, and I have this error when I go to http://WebsiteName.forum.install.upgrade.php.

    The "good" news... I did backup both my forum and my hostgator account before I did this "upgrade". So not all is lost. I would just like to have a working forum sometime today!

    Below is the error I'm receiving.

    PHP Code:
    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'root'@'localhost' (using passwordNO)
    /
    home/XXXX/public_html/WebSiteName.com/forum/includes/class_core.php on line 311

    MySQL Error   

    Error Number  
    Request Date  SaturdayOctober 10th 2009 03:21:19 PM
    Error Date    
    SaturdayOctober 10th 2009 03:21:19 PM
    Script        
    http://WebSiteName.com/forum/install/upgrade.php
    Referrer      
    IP Address    
    Username      
    Classname     vB_Database
    MySQL Version 


  • #2
    It means is that your mysql has crashed or went down, you need to contact your web host and ask why and get them to get it back up.

    Or...

    One or more of the following is wrong in your config.php file:

    $dbusername
    $dbpassword
    $dbname

    Or..

    Your mySQL user got deleted.

    Comment


    • #3
      Thank you for your reply...

      I double checked mysql and it wasn't down nor was it deleted.

      I did take a look at the config.php file and I'm a little lost as to where the information is it (username, password).

      Since I did backup my old vb, would I be better off just reinstalling it from scratch, then doing the back up? If so, would my template still be there, or would I lose that?

      Kris :-)

      Comment


      • #4
        I, too use hostgator. Have you looked at your old config.php? You can use the old config.php file.

        Templates are stored in the database. I think this is a simple issue. Examine the config.php file and comparte it to the original or just use the original.
        Last edited by dodgeboard.com; Sat 10 Oct '09, 5:07pm.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X