Announcement

Collapse
No announcement yet.

Upgrade 3.8.0 - 3.8.2 mysql-connect</a>]: Access denied

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade 3.8.0 - 3.8.2 mysql-connect</a>]: Access denied

    Code:
    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'root'@'localhost' (using password: NO)
    /home/jintan/public_html/includes/class_core.php on line 311
    What do I need to do to correct for this please? Thanks.

  • #2
    Use the correct information to connect to the server, you uploaded a blank config.php file, you need to edit the proper information into the config.php file.

    Comment


    • #3
      Good - could you point me to a link or page that shows how to do that? I had already read through searched threads in these forums earlier, when I ran into the config.php.new error, but haven't been able to locate info on how to fill in the config.php file or what info to put in it. Somehow I did the previous upgrade without having to do that, so am not familiar with this requirement. The forum had a Luckysploit mess I am now recovering from.

      Comment


      • #4
        Here is the online documentation explaining the config.php file and variables:

        http://www.vbulletin.com/docs/html/editconfig
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Thanks Steve, that placed me in the ballpark. Someone else has done the original setup for me, so I am not familiar with this. This error currently, if someone could shed light on the correction:

          Code:
          Invalid SQL:
          
          			SELECT *
          			FROM datastore
          			WHERE title IN ('','options','bitfields','attachmentcache','forumcache','usergroupcache','stylecache','languagecache','products','pluginlist','cron','profilefield','loadcache','noticecache');
          
          MySQL Error   : Table 'myforumsqldbname.datastore' doesn't exist
          I changed to that "myforumsqldbname" only due to just not knowing how much is to be public knowledge here. Thanks.

          Comment


          • #6
            Are you sure you have the right table prefix? Can you look at the database in phpmyadmin? Does every table have something like vb_ or vb3 myforum?

            Comment


            • #7
              It's listed there as forums_datastore, thanks. Everything there is "forums_name".

              Comment


              • #8
                I left this unchanged from the default in config.php so far:

                $config['Misc']['forumpath'] = '';

                Comment


                • #9
                  Change the table_prefix setting to forums_

                  Comment


                  • #10
                    Dead on - thank you Zachary. Just need to find where I locally stored the header graphic in the past to upload that again now. I appreciate the help.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X