Announcement

Collapse
No announcement yet.

Installation Problem..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation Problem..

    I have read around and tried to find similar threads for my problem but when I read the threads I became completely lost... I am new to vBulletin and I really would love some help..

    Here is the error I get on Step 2 of the installation process.

    Step 2) Connect to the database

    Attempting to attach to database


    Error description: mysql_connect() [function.mysql-connect]: Access denied for user 'myusername'@'host371.hostmonster.com' (using password: YES) /home3/myusername/public_html/forums/includes/class_core.php on line 311


    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.


    Any help would be appreciated .

  • #2
    The most likely cause of this error is that the info in your config.php file is wrong or your db user does not have full permissions to this database. Please read this for all the known causes of this error:

    http://www.vbulletin.com/forum/showthread.php?t=194542
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      This might possibly be the dumbest question, but what should go in here?
      - $config['Database']['dbname']

      Comment


      • #4
        Nothing there, but to the right of the equal sign and in quotes you place the name of the database. Did you create a database yet.

        Here is our online documentation for creating a new database and db user:

        http://www.vbulletin.com/docs/html/create_database

        And from the MySQL site:

        http://dev.mysql.com/doc/mysql/en/CREATE_DATABASE.html
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Thanks for the help! I got ahead and am now at step 9 and feel good. Thanks again for all the help.

          Comment


          • #6
            Hey thanks I got it up and running , but I was wondering on how making the forum homepage the main link.. When I go to my website it says this.

            "Index of /

            * forums/

            Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at totalsportsheaven.com Port 80"

            How can I make it so when you go to the mainpage it automatically redirects to the forum?

            Comment


            • #7
              You could actually move the files into the root and update any URLs in AdminCP > vBulletin Options or add an .htaccess file to the root folder to redirect all users.
              Vote for:

              - *Admin Settable Paid Subscription Reminder Timeframe*
              -
              *PM - Add ability to reply to originator only*
              - Add Admin ability to auto-subscribe users to specific channel(s)
              - "Quick Route" Interface...

              Comment


              • #8
                Originally posted by Trevster View Post
                You could actually move the files into the root and update any URLs in AdminCP > vBulletin Options or add an .htaccess file to the root folder to redirect all users.
                How would I move them into the root? I thought they were already in there?
                Sorry I am completely new at this but am willing to learn..

                Comment


                • #9
                  You have your forums in a folder called 'forums' by the look of your error messages above. To have them in the root folder, files such as index.php etc should be in the public_html folder or, depending on how your FTP client is configured, the only thing you should see in the address bar of the remote view will be '/'.

                  To move them, you can either:

                  - reupload the files other than install/install.php or
                  - copy and paste them over from within your FTP software
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - "Quick Route" Interface...

                  Comment


                  • #10
                    When I tried that I ended up with yet another error.

                    Comment


                    • #11
                      And what is that error?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Warning: require_once(/home3/totalsp1/public_html/includes/init.php) [function.require-once]: failed to open stream: No such file or directory in /home3/totalsp1/public_html/global.php on line 20

                        Fatal error: require_once() [function.require]: Failed opening required '/home3/totalsp1/public_html/includes/init.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home3/totalsp1/public_html/global.php on line 20

                        Comment


                        • #13
                          That error means that you have not uploaded all the vB files, specifically 'includes/init.php'.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Thank you so much!

                            Topic may be closed.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X