Announcement

Collapse
No announcement yet.

I upgraded from 3.7 to 3.8 and upload function stop

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I upgraded from 3.7 to 3.8 and upload function stop

    Hi guys,

    After I updated my forum from 3.7 to 3.8 the upload functions stop and I got message said I can't upload and that message came when I tray to upload picture in album, attach any file, change profile picture or upload picture for signature. I'm wondering if there are any permissions need to change?or did i forget some thing need to do after upgrading?!

    Thank you,

    Amin

  • #2
    The exact error is needed to determine which resolve path to take.

    Comment


    • #3
      Sorry the error message is
      Unable to move/cope file

      Comment


      • #4
        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

        Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          unfortunately, this steps do not work with my problem!

          Comment


          • #6
            Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

            Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I Enabled the Publicinfo() and the URL of the forum is http://www.mbt3th.us/vb

              Comment


              • #8
                You need to restore the full copyright first.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  You need to restore the full copyright first.
                  How I can do it?

                  Comment


                  • #10
                    Add this to the footer template:

                    <div class="smallfont" align="center">
                    <!-- Do not remove this copyright notice -->
                    $vbphrase[powered_by_vbulletin]
                    <!-- Do not remove this copyright notice -->
                    </div>
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Hi the change was in the language. anyway I got what you mean. what the next step?

                      Comment


                      • #12
                        Thank you.

                        You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory.

                        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

                        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Okay I did
                          tmp "777"
                          the Safe Mode Temporary Directory is"/home/mbt3th/public_html/tmp"
                          the Safe Mode Upload Enabled is "yes"

                          Comment


                          • #14
                            Then if you are still getting that error this is either a server issue, a problem with an add-on or you did not upgrade correctly.

                            To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                            [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                            Next, disable all plugins.

                            Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                            define('DISABLE_HOOKS', true);


                            Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

                            Do you have the same problem? If you do, this is as server issue and you need to contact your host.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              yes yes yes...
                              Thank you very much Mr.Machol.
                              The problem gone!!! I think because of "tmp" folder.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X