Announcement

Collapse
No announcement yet.

Database error with vB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database error with vB

    What would give us this error?

    Attempting to attach to database

    Connect failed: unexpected error from the database.

    Error number: 1044

    Error description: Cannot use database xxx

  • #2
    not sure but I been getting it also, it will on and off few times in a row

    Comment


    • #3
      To fix this run Repair/Optimize in the Admin CP. You may need to run it more than once to fix all errors:

      Admin CP -> Maintenance -> Repair/Optimize Tables -> Check All -> Continue

      If you cannot access the Admin CP you can also use phpMyAdmin to repair tables.

      If that doesn't work then this may be too damaged to fix with the normal methods. Please check out this thread for other ways to repair a db, particularly items #2 and 3:

      http://www.vbulletin.com/forum/showt...threadid=44909

      You may have to ask your host to try and repair this for you.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Originally posted by Steve Machol View Post
        If you cannot access the Admin CP you can also use phpMyAdmin to repair tables.
        Tables? There are no tables. We are just running install now and it gave us that error right after it confirmed the config file was OK. (I think it was step two or three)

        Should we just delete the database and install a new one?

        (since this one is completely empty)

        Comment


        • #5
          Error 1044 is a permissions error - make sure the user has full permissions set for the database, and that you have assigned a user to it. (usually done in your hosting control panel)
          Lats...

          Comment


          • #6
            If you have no tables in the database, then that is the problem right there.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X