Announcement

Collapse
No announcement yet.

Stuck on step 2 during fresh install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stuck on step 2 during fresh install

    It's giving me the following error during step 2 of the installation:

    Step 2) Connect to the database
    Attempting to attach to database
    Error description: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/usr/local/mysql-5.0/data/mysql.sock' (2) /home/content/d/f/w/dfwcharity/html/forums/includes/class_core.php on line 311
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.


    I just spent 45 minutes on the phone with my webhost, and they assure me they are able to access my databases on their end without any issues. I followed directions on editing the config file... What am I missing?

    -Lee

  • #2
    This means that the information in config.php is incorrect. The main reason for this particular error is that the mysql server name is wrong.

    Adjust your config.php file as required, overwrite the file on your server with the newly edited version, then restart the installation.
    Kerry-Anne :)

    Twitter Blog

    www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

    Comment


    • #3
      Originally posted by Kerry-Anne View Post
      This means that the information in config.php is incorrect. The main reason for this particular error is that the mysql server name is wrong.

      Adjust your config.php file as required, overwrite the file on your server with the newly edited version, then restart the installation.
      I pulled the server name straight off of my account information...

      'p41mysql61.secureserver.net'

      Is there another line in the config file that could be wrong and causing this error?

      Many thanks.

      Comment


      • #4
        Originally posted by Deviate View Post
        I pulled the server name straight off of my account information...

        'p41mysql61.secureserver.net'
        Try "localhost" (in case of Yahoo:"mysql")


        vB5 is unequivocally the best forum software, but not yet...

        Comment


        • #5
          The four items that are the ones that cause connection errors during the installation process are:

          MySQL Server Name
          Database Name
          User Name
          Password

          Only you and your host know what the correct information for these will be.
          Kerry-Anne :)

          Twitter Blog

          www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

          Comment


          • #6
            Originally posted by beishe8 View Post
            Try "localhost" (in case of Yahoo:"mysql")
            Tried that first. Didn't work either.

            Originally posted by Kerry-Anne View Post
            The four items that are the ones that cause connection errors during the installation process are:

            MySQL Server Name
            Database Name
            User Name
            Password

            Only you and your host know what the correct information for these will be.
            I've set up an entirely new database and entered all of the new information into the config file. Still nothing.

            I'm convinced at this point that it's something wrong on the server side. The MySQL communication error I'm getting with vB is the same error I was getting with phpBB3 after almost a year of fairly smooth running. Now the difficult part is going to be convincing them to even take it seriously enough to put some effort into fixing it.

            Comment


            • #7
              Thanks for the help.

              It helps to have friends that know what they're doing. I was able to get a friend of mine to help me through the process, so it's up and running well.

              I did have some issues while transfering the old phpBB3 users to vB. Instead of moving my "Registered Users" group to vB's RU group, it made a new group for them titled "REGISTERED" where the entire group was permabanned. Thankfully I found that out before I went live with it.

              Comment


              • #8
                It would be helpful to others if you would inform us what you found and what you changed...

                Comment


                • #9
                  yes i have the same problem

                  Please send me what you did... I have the same problem with GoDaddy.com hosting.

                  Comment


                  • #10
                    GoDaddy doesn't normally use the localhost for mysql, its usally something like server23.secureserver.net.

                    Contact godaddy for more help with your mysql information. Your host has the anwsers.

                    Comment


                    • #11
                      Originally posted by dos0711 View Post
                      It would be helpful to others if you would inform us what you found and what you changed...
                      I changed out the least reliable part of any operation; the operator.

                      I can't really say what was changed as I didn't do it myself, hence the previous comment about having friends that know what they're doing.

                      I asked him what it was that I had done wrong, and I'm sure he gave me the answer. I either didn't understand it (strong possibility), I forgot it (also a strong possibility), or a combination of the two (most likely what happened). Wish I could be of more help to others with the same issues. Now if it were a question about why someone's BMW is running rough, I can help... This whole database stuff is well outside my area of expertise.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X