Announcement

Collapse
No announcement yet.

Database connection error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Yes, ticket has already been opened and Steve Machol has been trying to help, although I think Marco might have some more thoughts tomorrow.
    Retro Amiga gaming. Come visit us as http://www.classicamiga.com

    Comment


    • #17
      Some great news! I finally got it to work!!! :-)

      This is what I had to do:

      1, From the 1and1 Control Panel - Go to the server Administration section and make sure PHP is running as a module.

      2, Create a .htaccess file and put the following line into it.

      php_value mysql.default_socket "/tmp/mysql5.sock"

      And put this .htaccess file into the root of the forum directory.

      3, Enter the following settings into the vB config.php file.

      $config['MasterServer']['servername'] = 'localhost';
      $config['MasterServer']['port'] = '/tmp/mysql5.sock';

      Finally I had to run tools.php to reset the cookie settings before I could log into the forum's admincp. And now everything is working again.
      Last edited by Amiga Harrison; Thu 26 Feb '09, 4:45pm.
      Retro Amiga gaming. Come visit us as http://www.classicamiga.com

      Comment


      • #18
        That's good news for you, and future 1and1 clients
        Lats...

        Comment


        • #19
          Worked for me too .

          Comment


          • #20
            OMG, days and days I've had an issue with this,

            many thanks

            Comment


            • #21
              Hi there,

              I have been also fighting with this for a few weeks now. I am on a shared hosting server and my hosts moved me over to a newer shared hosting server. This seems to have fixed the multitude of database connection errors I was getting. I did not "update" my config.php as per Amiga Harrison's suggestion, but I have asked my hosts to please give me a run down of the difference between the 2 servers. I will post that info as there seems to be a lot of these errors popping up around the world, as service providers upgrade their MySql, Apache, PhP etc...

              Nonetheless, I do host with other hosts and run different software and if I do need to implement the above solution, where exactly do I enter the following settings into the vB config.php file?

              $config['MasterServer']['servername'] = 'localhost';
              $config['MasterServer']['port'] = '/tmp/mysql5.sock';

              Do I put the 2 lines under Database Type like so?

              // ****** DATABASE TYPE ******
              // This is the type of the database server on which your vBulletin database will be located.
              // Valid options are mysql and mysqli. Try to use mysqli if you are using PHP 5 and MySQL 4.1+
              $config['Database']['dbtype'] = 'mysql';
              $config['MasterServer']['servername'] = 'localhost';
              $config['MasterServer']['port'] = '/tmp/mysql5.sock';

              Thanks and regards,

              Comment


              • #22
                Originally posted by mandrinsa View Post
                Do I put the 2 lines under Database Type like so?

                // ****** DATABASE TYPE ******
                // This is the type of the database server on which your vBulletin database will be located.
                // Valid options are mysql and mysqli. Try to use mysqli if you are using PHP 5 and MySQL 4.1+
                $config['Database']['dbtype'] = 'mysql';
                $config['MasterServer']['servername'] = 'localhost';
                $config['MasterServer']['port'] = '/tmp/mysql5.sock';
                Notice the comment above that. Database Type. That means only the var for the dbtype should be there. Look further down the page for servername var and it should go there.
                That's it. If you REALLY can't say ANYTHING nice to me at all on this forum, then I am going to go insanely mad at you. I've had enough of the UNTOLD ABUSE you are all giving me and you should really be CONSIDERATE of other people.

                Comment


                • #23
                  Ahhh, not add but rather overwrite.
                  Forgive the noobishness

                  Ta for the help.

                  Comment


                  • #24
                    Originally posted by Zachery View Post
                    The socket is the port.
                    I had this problem too, this comment was the "aha moment" for me. Just put the /tmp/mysql5.sock in the port line and you're good to go.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X