Announcement

Collapse
No announcement yet.

Database errors after 3.8.1 upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database errors after 3.8.1 upgrade

    Hi,

    Ive just upgraded from 3.6.8 to 3.8.1 and all seems ok except for the admincp:

    Code:
    Database error in vBulletin 3.8.1:
    
    Invalid SQL:
    
        SELECT COUNT(*) AS count
        FROM moderation AS moderation
        INNER JOIN post AS post USING (postid)
        WHERE moderation.type='reply';
    
    MySQL Error   : Unknown column 'postid' in 'from clause'
    Error Number  : 1054
    Request Date  : Friday, February 6th 2009 @ 11:03:42 PM
    Error Date    : Friday, February 6th 2009 @ 11:03:43 PM
    Script        : http://www.domain.com/vb/admincp/index.php?do=home
    Referrer      : http://www.domain.com/vb/admincp/index.php?do=nav
    IP Address    : 123.45.67.890
    Username      : Fisco
    Classname     : vB_Database
    MySQL Version : 5.0.67-community
    (ive changed the IP and Domain)

    Ive searched these forums all over and tried everything i could find:

    • admincp is the correct directory both on the server and in config.php
    • admincp folder was uploaded as ASCII and overwrote all previous files

    and quite a few others ive come across........

    Any advice is greatly appreciated.

  • #2
    That error is from an old file or an add-on that is asking for a field that no longer exists in vB 3.8.1.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I mean no offense and your reply is greatly appreciated but that seems to be a pretty standard reply to this issue.

      Ive tried everything youve mentioned already with no sucess.

      Comment


      • #4
        It's a standard reply because it's true. You cannot get that error if you followed my instructions for the simple reason that there is NO 'postid' field in the 3.8.1 moderation table. That error is coming from an add-on or a old file.

        If you do not believe me, look at the moderation table yourself. You can also check the vB schema in the install/mysql-schema.php file.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Its not a case of whether i believe you or not as im sure what you suggested works 9/10 times but not in this instance.

          I have uploaded the admincp folder via ASCII overwriting all existing files.

          I have totally removed the admincp folder and uploaded and extracted a zip of the admincp folder.

          I have added define('DISABLE_HOOKS', true); to the config.php file

          No matter which posts i look at or suggestions i try the problem still exists, im not the kind of person who creates threads without searching first, i spent at least an hour looking through threads on this issue and came across plenty of threads where people have had the same issue but been met with the exact same "copy and paste" reply, again, its evident by some peoples replys (or lack of) that it does indeed fix this 9/10 times but not in this instance.

          I actually said in my op that i had checked the folders & config file and also uploaded the files using ASCII so there was no need to suggest doing that. Unless theres other things that might be causing it, my only other option is to remove the whole account and try from fresh using the existing database.

          Comment


          • #6
            If you followed all of those instructions, what does Suspect Files show? You simply cannot get that specific error if you followed all of those instructions.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X