Announcement

Collapse
No announcement yet.

Upgrade Problem: MySQL Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RvG
    replied
    just edit the collation of table prefixid

    Leave a comment:


  • car20
    replied
    dear chrischristian
    can you explain how do i solved this Problem

    Leave a comment:


  • chrischristian
    started a topic Upgrade Problem: MySQL Error

    Upgrade Problem: MySQL Error

    Tried to upgrade today from vB 3.7.4 to vB 3.8.0 Gold.

    MySQL is 5.0.67-community-nt (memcached) and php is 5.2.8 FastCGI (IIS 6) with eAccelerator.

    Error:


    Step 5) Upgrade to vBulletin 3.8.0 Alpha 2 Complete!
    Database error

    Database error in vBulletin 3.7.4:
    Invalid SQL:
    SELECT prefix.*, prefixpermission.usergroupid AS restriction
    FROM vb_prefix AS prefix
    LEFT JOIN vb_prefixpermission AS prefixpermission ON (prefix.prefixid = prefixpermission.prefixid)
    ORDER BY prefix.displayorder;
    MySQL Error : Illegal mix of collations (latin1_general_ci,IMPLICIT) and (latin1_swedish_ci,IMPLICIT) for operation '='
    Error Number : 1267
    Request Date : Saturday, January 17th 2009 @ 11:21:15 AM
    Error Date : Saturday, January 17th 2009 @ 11:21:15 AM
    Script : /install/upgrade_380a2.php?step=5
    Now, the upgrade system refuses to continue, always shows this error.

    How to fix this?


    EDIT:
    Problem solved. Changing the collation of the table prefixid solved the problem.
    Last edited by chrischristian; Sat 17th Jan '09, 5:44am.

Related Topics

Collapse

Working...
X