Announcement

Collapse
No announcement yet.

Error during upgrade to 3.8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error during upgrade to 3.8

    Hi,

    I am trying to upgrade from 3.72 to 3.8 and received this error:

    Invalid SQL:

    DELETE FROM vb_phrase
    WHERE product IN ('vbulletin', '')
    AND fieldname = 'cphelptext'
    AND languageid = -1;

    MySQL Error : Table './wwwcoor_coordinatorscornerdb/vb_phrase' is marked as crashed and should be repaired
    Error Number : 145
    Request Date : Wednesday, January 14th 2009 @ 12:06:15 PM
    Error Date : Wednesday, January 14th 2009 @ 12:06:17 PM
    Script : install/finalupgrade.php?step=2
    Referrer : install/finalupgrade.php?step=2
    IP Address : 74.170.121.94
    Username :
    Classname : vb_database
    MySQL Version : 5.0.67-community


    I have contacted the hosting company to report the database error, however I was wondering if anyone here can give me an idea of what this issue is.

    Also, once the issue is resolved how do I proceed with the upgrade. Do I just start from the beginning again?

    Thank you for assistance,
    sabernethy

  • #2
    To fix this run Repair/Optimize in the Admin CP. You may need to run it more than once to fix all errors:

    Admin CP -> Maintenance -> Repair/Optimize Tables -> Check All -> Continue

    If you cannot access the Admin CP you can also use phpMyAdmin to repair tables.

    If that doesn't work then this may be too damaged to fix with the normal methods. Please check out this thread for other ways to repair a db, particularly items #2 and 3:

    http://www.vbulletin.com/forum/showt...threadid=44909

    You may have to ask your host to try and repair this for you.

    After this is repaired just run the upgrade again. It should restart at the correct point.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thank you very much!

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X