Announcement

Collapse
No announcement yet.

Help.. I upgraded and now this

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help.. I upgraded and now this

    Database error in vBulletin 3.8.0 Beta 1:
    Invalid SQL:
    SELECT COUNT(*) AS countmessages FROM groupmessage WHERE groupid='1';
    MySQL Error : Unknown column 'groupid' in 'where clause'
    Error Number : 1054


    Everything went fine on the upgrade but now I have an error and my forum is down. I can access the adminCP just fine but I need some help on this one.


    Thanks in advance!



    -Dave

  • #2
    What's the complete error?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Database error in vBulletin 3.8.0 Beta 1:
      Invalid SQL:
      SELECT COUNT(*) AS countmessages FROM groupmessage WHERE groupid='1';
      MySQL Error : Unknown column 'groupid' in 'where clause'
      Error Number : 1054
      Request Date : Thursday, October 9th 2008 @ 06:56:59 PM
      Error Date : Thursday, October 9th 2008 @ 06:57:00 PM
      Script : http://www.thelovelogic.com/forum/
      Referrer : http://www.thelovelogic.com/forum/me...perdave71.html
      IP Address : 75.66.88.206
      Username : SuperDave71
      Classname : vb_database
      MySQL Version : 5.0.67-log

      Comment


      • #4
        <Moved to correct forum.>

        There is no 'groupid' field in the 3.8 groupmessage table. This is either from an add-on or old file.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I will do as instructed and get back ASAP.

          THANK YOU!


          -Dave

          Comment


          • #6
            I have it back up but closed. I disabled all plug-ins and created a new style. Everything was looking good until I looked at the User Profiles. The use profiles regardless if you create new style show nothing but the images.

            I want to get my forum up and running as soon as I can. I really appreciate your help on this matter. I have followed your instructions to the tooth.


            I will be happy to give you access to anything you may need if you would like to take a look.


            Thank you so much!


            -Dave

            Comment


            • #7
              You need to follow all those instructions. I can't imagine this problem if you did, unless you skipped one or more steps in the upgrade.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Sorry for the misunderstanding. I followed all your instructions and though it is back up, (but closed) there are several pages that only have text, no images nor styles.



                Is there a way to revert back to the latest 3.7? I have all my tables backed up.



                -Dave

                Comment


                • #9
                  You might try reuploading your pages again. Make sure all php pages are uploaded in ASCII and images in Binary.

                  If you decide to go back to whatever you were running before, you should put all the files back up for that version and then restore your backed up database. Make sure if your database is for 3.7.2, then you put your 3.7.2 files back or else you will need to run the upgrade script (like if you put 3.7.3 files up and your database is only 3.7.2).

                  Please don't PM or VM me for support - I only help out in the threads.
                  vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                  Want help modifying your vbulletin forum? Head on over to vbulletin.org
                  If I post CSS and you don't know where it goes, throw it into the additional.css template.

                  W3Schools &lt;- awesome site for html/css help

                  Comment


                  • #10
                    I am reupping Latest Version: 3.7.3 Patch Level 1

                    Since I am downgrading, do I need to make sure my upgrade script is for 3.7.3?



                    I just want to be clear so there is no confusion.


                    I was running 3.7.3 Patch Level 1 perfectly before I upgraded. I upgraded to 3.8 and now I am going to revert back to what I had.


                    Thank you so much and I apologize for the confusion.


                    -Dave

                    Comment


                    • #11
                      There is no way to downgrade to a older version of vBulletin. You'd have to have a database backup/dump.

                      Did you do that before upgrading? (backup)

                      Comment


                      • #12
                        Yes, thank you. I am fully backed up. Restoring database now. This could take a while. HAHA

                        -Dave

                        Comment


                        • #13
                          Yeah I might wait until 3.8 is out of beta or is it already.
                          vBulletin.com great hosting guide made by me. 2,000+ Views
                          Hosting Guide.

                          Proud vBulletin License Owner!
                          Did I help you out? Please give me a cookie then!
                          http://cookyx.com/new/158.png
                          Edlinpugs | Clan WrT

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X