Announcement

Collapse
No announcement yet.

Problems with line breaks when sending e-mails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with line breaks when sending e-mails

    When I send e-mails via a cloud forum, there are problems with line breaks.

    Actually, the diagnostic email should look like this:

    You are receiving this email because your email address was entered as an email test at myforum

    The first step of this email test script has been completed. However, a formatting test is still necessary:

    A paragraph break.
    A single line break.

    Another paragraph break.
    Another single line break.
    Another single line break.

    If the above lines look correct, you are finished. The email features on your server are setup correctly.
    If this email is run together on one line, there is possibly a configuration error with your mail server. Please ensure it is configured correctly.
    Unfortunately it looks like this:

    You are receiving this email because your email address was entered as an email test at Forums.

    The first step of this email test script has been completed. However, a formatting test is still necessary:

    A paragraph break. A single line break.

    Another paragraph break. Another single line break. Another single line break.

    If the above lines look correct, you are finished. The email features on your server are setup correctly. If this email is run together on one line, there is possibly a configuration error with your mail server. Please ensure it is configured correctly.
    Especially in the footer of an e-mail this should be true. How can this be adapted?

    Regards,

    Nils

  • #2
    Emails are sent into plain text. If your client tries to convert them to HTML, this will happen. What client are you using?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Thanks for the quick answer.

      Of course, I tested it extensively in advance with several cloud forums and several clients.

      The clients are Outlook (O365), Mail on the iPhone or a horde webmail. All with this result.

      But what I have just seen is that the format is adapted by the cloud forum and certainly has no text encoding. This is actually the much more problematic part, because there seems to be a tracking integrated? You can see this with links:

      http://links.vbulletin.net/wf/click?upn=vKJqU....

      How can I turn it off? Pure text e-mails would make much more sense for us.

      Regards,

      Nils
      Last edited by NilsD.; Tue 26th Feb '19, 12:26pm.

      Comment


      • #4
        What is the address of your Cloud site?

        The link goes to a bad URL so not sure where it is coming from.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          The forum of this link is not published yet. Therefore I shortened it.

          Here is a link from my test forum:

          https://www.google.de


          Code:
          http://links.vbulletin.net/wf/click?upn=vKJqUwKuExrI8Dtpc8DvlKoiA4uTc8CK62jsBX1PwgM-3D_MbhpfpMnDpc9g510u75hsmEigFSGfT9oWXTx2F4Edkbm1Hs-2BA3qao3w4UQp-2BNxUAa3EXVm1dvv4IRkeVNNwSthw9Z6Zx9OJLGS9gwqYCIvKA-2F2madmWCdSL6krrUJfEtl6pNt3C9Wo6SAFzdzffo2AtJquI9NZRLCF-2FFeehF-2FgX9Oi0GOcMRmLNadCnxsZiB4DbxahuGo98wuGIKptd-2B4A-3D-3D
          Here are the settings in the template:

          Click image for larger version  Name:	2019-02-26 23_14_46-Phrase Manager- Forums - vBulletin Admin Control Panel.png Views:	0 Size:	107.1 KB ID:	4409523

          Here the result e.g. in Outlook:

          Click image for larger version  Name:	2019-02-26 23_15_44-Mail.png Views:	0 Size:	34.4 KB ID:	4409524

          and here some details about encoding:

          Content-type: multipart/alternative; boundary="----------=_1551219326-5148-410"

          I'm very interested in the resolution now.

          Regards,

          Nils

          Comment


          • #6
            Originally posted by NilsD. View Post
            I'm very interested in the resolution now.
            Since your forum account doesn't link to your customer account. I can't provide any kind of resolution before I know what the URL of your cloud site is.

            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              As you can see in the picture above, this is: https://www.forenguru.net/

              But the page is not adapted and you can reproduce the behavior with other vB cloud forums.

              Regards,

              Nils

              Comment


              • #8
                Originally posted by Wayne Luke View Post
                Since your forum account doesn't link to your customer account.
                He should. I am not aware of any other site than this one to create the link:

                https://members.vbulletin.com/member...t_priority.php

                Or what else do I have to do?

                Comment


                • #9
                  The link is inserted by the email provider. We've turned them off in their settings. Still looking at the other issue.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #10
                    The links are now displayed normally again. "text/plain" is now the format again. The problem of origin has now been reversed:
                    Code:
                     
                    
                    You are receiving this email because your email address was entered as an email test at DomainFactory Supportforum.
                    
                    
                    
                    The first step of this email test script has been completed. However, a formatting test is still necessary:
                    
                    
                    
                    A paragraph break.
                    
                    A single line break.
                    
                    
                    
                    Another paragraph break.
                    
                    Another single line break.
                    
                    Another single line break.
                    
                    
                    
                    If the above lines look correct, you are finished. The email features on your server are setup correctly.
                    
                    If this email is run together on one line, there is possibly a configuration error with your mail server. Please ensure it is configured correctly.
                    Too many breaks are now existing.

                    Regards,

                    Nils

                    Comment


                    • #11
                      Is there any news here after 4 months? The e-mails from the cloud forums still look impossible due to the multiple line breaks?

                      Regards,

                      Nils

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X