Announcement

Collapse
No announcement yet.

Question on using Style Variable Editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question on using Style Variable Editor

    I am not sure of the correct terminology but I want to change the white background to a different color. By background I mean the area where it shows all the threads / around and including all background of posts themselves. Which settings do I need to change the colors in? I have tried by trial and error but it is just taking too long.

    Also is there image somewhere showing what each code changes on the screens for reference? That would be immensely helpful.

    Thanks.

  • #2
    I'm not sure what background you are describing. Can you take a screen shot and point it out in the screen shot.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      It does take a lot of trial and error, which is not fast.

      I guess you have found the style editor: Styles & Templates > Style Manager > Edit Style

      In the Global category, try editing wrapper_background. I don't recall everything that will change if you do this, but I think it's generally the area you are describing.

      Comment


      • #4
        This is the general area I am talking about, basic complaint is that the forum is to bright so I am looking to change the white to more grayish.

        Comment


        • #5
          Try the stylevar wrapper_background as McWebmaster suggested.

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools <- awesome site for html/css help

          Comment


          • #6
            Thanks that did the trick. I had to change it too black though to get a grey color.

            Comment


            • #7
              That seems odd. You might want to check how it looks in multiple browsers (Firefox, Explorer, Safari, Chrome). You could also experiment with using a plain background image instead of a background color. Just guessing, I am still learning how this works myself.

              Comment


              • #8
                Well I learned (and this is a big pain) that after I change the color and it saves it can take 5 to 10 minutes for it to actually show up on website. Thats why when it didnt change with grey I went to black and thought it worked but it was just a delay. Later it turned to black. So not know what does what exactly is a huge hassle because I have to wait for something to change to see what it is.

                Comment


                • #9
                  Next time, try emptying the browser cache, and doing a double refresh. The changes should show up immediately. System cache may need to be flushed also.


                  Comment


                  • Wayne Luke
                    Wayne Luke commented
                    Editing a comment
                    Cloud is a bit slower as the CSS files need to replicate across different servers. We're working on that and newer replication is faster so instead of 5-10 minutes it is 1-2. Still not instant but more bearable we hope.

                • #10
                  Can someone let me know which option changes the color of this section?

                  Comment


                  • #11
                    I believe that is the stylevar primary_module_subheader_background.
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.5.6 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #12
                      Ok thanks I will give it a try, its been eluding me for a while now!

                      Comment


                      • #13
                        Doesn't appear to have worked so it must be something else. I didn't notice anything change and its been at least 20 minutes. Any other ideas of which one it could be?

                        Comment


                        • #14
                          It definitely is that one. I just tested it.

                          Are you viewing the site in the correct theme?

                          Note the difference between "vBulletin Default Style" and "Default Style" - although they both look the same, they are two distinct themes. If you're editing "Default Style" but viewing the site in "vBulletin Default Style" (which is what is displayed to guests looking at your site) then you aren't going to see the changes.
                          Last edited by Mark.B; Sat 15th Nov '14, 9:17am.
                          MARK.B | vBULLETIN SUPPORT

                          TalkNewsUK - My vBulletin 5.5.6 Demo
                          AdminAmmo - My Cloud Demo

                          Comment


                          • #15
                            I was looking at correct theme, I cant edit the default styles anyways and have to create a new one. Yes it was the right one. Not sure what the issue was...... It showed that was changed in the Admin CP when I made the change originally. I had to go back in and save it again for some reason for it to take this time. Must of had a hiccup originally. Thanks for getting back to me!

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X