Announcement

Collapse
No announcement yet.

Vb 3.8 - Cache Options!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vb 3.8 - Cache Options!

    So my website has recently started to get more traffic (15K pageviews per day). Since then the database is frequently going away with errors like (too many connections).

    I spoke the hosting people (hostgator) and they told me that I need to change the cache options in vbulletin to remedy this issue.

    I have no idea what are cache options nor how do I tweak them.

    Would you please help me!

  • #2
    Using a datastore cache will not fix the too many connection errors.
    What are the specific error messages that you're getting?

    Comment


    • #3
      unfortunately I deleted the emails that I got yesterday. But it was something like "too many connections, mySQL gone away, and the URL is the home page".

      I will post the database error once I get it again.

      Comment


      • #4
        The specific errors are very helpful for debugging the real issue.

        Comment


        • #5
          It sounds like they have a limit on the amount of connections that can be used per account, or for the entire server, I highly doubt they will raise it for one user, I think the main thing is, Find a host that isn't so restrictive or that doesn't mind raising the limits when you ask. Hostgator isn't going to do much for you, unless you have a dedicated server, which is something you don't need anyways, I'd suggest finding a new host.

          Comment


          • #6
            ask your host to increase your mysql connection limit
            MobilePhoneTalk.Com - Mobile Phone Community Powered By EuroVPS.Com

            Comment


            • #7
              Originally posted by ryan1918 View Post
              It sounds like they have a limit on the amount of connections that can be used per account, or for the entire server, I highly doubt they will raise it for one user, I think the main thing is, Find a host that isn't so restrictive or that doesn't mind raising the limits when you ask. Hostgator isn't going to do much for you, unless you have a dedicated server, which is something you don't need anyways, I'd suggest finding a new host.
              Yeah, I was thinking along these lines. But they denied that moving to a dedicated server will solve the problem.
              But I think you are right, they just want to push me to dedicated server.

              Comment


              • #8
                Originally posted by rajubd View Post
                ask your host to increase your mysql connection limit
                I already did, they said am already having the maximum limit!

                Comment


                • #9
                  They have no idea what they are talking about than, I'd suggest moving ASAP.

                  Comment


                  • #10
                    A lot of shared hosts have a max of 100 mysql connections allowed. I know my Goaddy shared account was like that, but I think they updated the limit. When I switched to Godaddy grid shared hosting, it went to a minimum of 600 mysql connections. I wouldn't recommend Godaddy for Hosting at all, and that is why I switched, but even if you had 100 mysql connections, the problem your having is odd. From what I know and was told, your database isn't always connected, as cache comes into play, for your topics, etc. So unless you have a few hundred people all online at the same time, I can't imagine you having a problem.

                    When I had godaddy shared with 100 connections, I had up to 150 users on at the same time, and never had those issues.

                    Comment


                    • #11
                      The exact error would help. There can be many reasons for too many connections.
                      Shamil Nunhuck, - Radon Systems Ltd.
                      VPS + Dedicated Server Hosting and Management
                      vBulletin Hosting and Services
                      Server / Website Consultation

                      Comment


                      • #12
                        eurovps shared server have to mysql connection limite
                        MobilePhoneTalk.Com - Mobile Phone Community Powered By EuroVPS.Com

                        Comment


                        • #13
                          Originally posted by rajubd View Post
                          eurovps shared server have to mysql connection limite
                          I don't understand your post? It doesn't make sense? He is asking about a specific problem, not a recommendation of what other hosts offer.

                          Comment


                          • #14
                            Just mainly ask them if they can increase the limit, or if you can upgrade your account, or just go with a better shared hosting company, or go with a vps that has a dedicated amount of ram, at least 2GB/4GB which should have no problem running your site.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X