Announcement

Collapse
No announcement yet.

A little help with my host if possible?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • A little help with my host if possible?

    Hi there,

    i'm using custom VPS from godaddy .. But i keep facing a lot of different problems with the cPanel .. but godaddy doesnt wants to help as they say i'm using the unmanaged plan .. if any of you nice members could advice me?

    FATAL ERROR: register_globals is disabled in php.ini, please enable it!
    and i receive this email as well :
    [checkperlmodules] The perl module PNGgraph could not be installed.
    This module is required by cPanel, and the system may not function correctly until it is installed, and functional. Below is the results of the auto-install attempt:

    Test Run
    ==============
    Can't locate PNGgraph.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl .) at - line 1.
    BEGIN failed--compilation aborted at - line 1.

  • #2
    Well Godaddy is not a greatest place for servers. (just my opinion).

    What are you trying to do ? Did you get that error running Vbulletin ?

    You registar globals are off, which is a good thing for security reasons.
    If you really need it, you can edit your php.ini to globaly enable it (not recommanded), then restart apache, or you can add an .htaccess at the root of your php script which requires registar_globals on.
    BPowers.com: Eu Web Hosting Solutions
    Shared hosting with Cpanel/Fantastico
    Live Help: http://www.bpowers.com

    Comment


    • #3
      From root ssh run /scripts/checkperlmodules and see if that fixes you issue with the pm, if not you will need to install it.

      Maybe something like
      /scripts/perlinstaller Chart::PNGgraph

      Also if you change to edge and run /scripts/upcp from root it should also fix the issue.

      Joey
      Real Web Host

      Comment


      • #4
        You should be able to modify this yourself by editing /etc/php.ini . By default on Godaddy servers and make sure register_globals is turned on. It will be much better option for you to go for Managed services to avoid such problems in future.
        Website Hosting | VPS Hosting | Dedicated Hosting
        Email & MSN: [email protected]

        Comment


        • #5
          I've found the php.ini file. But i have no idea how to change the save mode from off to on. Please advice. Thanks for the repsonse guys.

          Comment


          • #6
            some php directives can be overwritten. Try setting up a .htaccess file in your root directory, with the following in it

            php_flag register_globals on
            www.MJWebhosting.com - (Vbulletin Forum Hosting)
            www.MercuryServer.com - (Our vBulletin forum Managed & hosted by MJWebhosting)

            Comment


            • #7
              Hope its sorted out now Freezefusion
              Website Hosting | VPS Hosting | Dedicated Hosting
              Email & MSN: [email protected]

              Comment


              • #8
                Thanks to everybody who had responded to help .. I've resolved the issue .. thanks a lot .. reps have been added to all ..

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X