Announcement

Collapse
No announcement yet.

Mozilla style sheets

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mozilla style sheets

    Anyone know how to make the following snippit from a style sheet work in Mozilla, Netscape and IE? [doesn't work in Mozilla at the moment]

    A:link { COLOR: #0000FF; TEXT-DECORATION: none}
    A:visited { COLOR: #800080; TEXT-DECORATION: none}
    A:active { COLOR: #009900; TEXT-DECORATION: underline}
    a:hover { COLOR: #FF0000; TEXT-DECORATION: underline}

    Thanks
    http://forums.cpfc.org/

  • #2
    I use similar code and it works fine in Mozilla. Another thing you may want to try is this:

    :link { color: #0000ff; text-decoration: none }
    :visited { color: #800080; text-decoration: none }
    :link:hover, :visited:hover { color: #ff0000; text-decoration: underline }
    :link:active, :visited:active { color: #009900; text-decoration: underline }

    Comment


    • #3
      Originally posted by Zen
      I use similar code and it works fine in Mozilla. Another thing you may want to try is this:

      :link { color: #0000ff; text-decoration: none }
      :visited { color: #800080; text-decoration: none }
      :link:hover, :visited:hover { color: #ff0000; text-decoration: underline }
      :link:active, :visited:active { color: #009900; text-decoration: underline }
      nope - links are remaining underlined until they become 'visited'
      http://forums.cpfc.org/

      Comment


      • #4
        Can you post a URL to your page please?

        Comment


        • #5
          www.cpfc.org
          http://forums.cpfc.org/

          Comment


          • #6
            Try taking out the <style> and </style> tag from styles/1.css

            Comment


            • #7
              Try this:
              HTML Code:
              a {text-decoration: none;}
              a:link {color: #0000ff; text-decoration: none;}
              a:visited {color: #800080; text-decoration: none;}
              a:active {color: #009900; text-decoration: underline;}
              a:hover {color: #ff0000; text-decoration: underline;}
              You're my Prince of Peace
              And I will live my life for You

              Comment


              • #8
                Originally posted by nuno
                Try this:
                HTML Code:
                a {text-decoration: none;}
                a:link {color: #0000ff; text-decoration: none;}
                a:visited {color: #800080; text-decoration: none;}
                a:active {color: #009900; text-decoration: underline;}
                a:hover {color: #ff0000; text-decoration: underline;}
                nice one - worls great
                http://forums.cpfc.org/

                Comment


                • #9
                  You're still doing it wrong, you shouldn't have <style> etc. in your .css file. ONLY the actual core CSS definitions are supposed to go in there. Also, Zen's initial code is how it _should_ be done...

                  Comment


                  • #10
                    Hullo nice people - I'm having more issues with moz and css

                    Can you tell me why the following doesn't appear to work in moz



                    BODY {FONT-FAMILY: Verdana, Arial, Helvetica, sans-serifscrollbar-face-color:white;scrollbar-arrow-color:red;scrollbar-track-color:white;margin: 0px 0px;}
                    http://forums.cpfc.org/

                    Comment


                    • #11
                      Originally posted by Dave#
                      Hullo nice people - I'm having more issues with moz and css

                      Can you tell me why the following doesn't appear to work in moz



                      BODY {FONT-FAMILY: Verdana, Arial, Helvetica, sans-serif scrollbar-face-color:white;scrollbar-arrow-color:red;scrollbar-track-color:white;margin: 0px 0px;}
                      is it just me or did you forget a space somewhere? (the ez guess)

                      Comment


                      • #12
                        Originally posted by Faranth
                        is it just me or did you forget a space somewhere? (the ez guess)
                        thanks but there is a space there - it's just the formatting was lost in this new funky rich text interface thing
                        http://forums.cpfc.org/

                        Comment


                        • #13
                          Originally posted by Dave#
                          Hullo nice people - I'm having more issues with moz and css

                          Can you tell me why the following doesn't appear to work in moz



                          BODY {FONT-FAMILY: Verdana, Arial, Helvetica, sans-serifscrollbar-face-color:white;scrollbar-arrow-color:red;scrollbar-track-color:white;margin: 0px 0px;}
                          take a look up there, i spaced it for you

                          Comment


                          • #14
                            Originally posted by Faranth
                            take a look up there, i spaced it for you
                            I think you misunderstand, there is a space when you view the stylesheet

                            http://cpfc.org/styles/1.css

                            It's only this enhanced (sic) VB interface which is messing with the formatting
                            http://forums.cpfc.org/

                            Comment


                            • #15
                              ah sry nvm ^_^"''

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X