Announcement

Collapse
No announcement yet.

Users gettting failed errors after registering...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Users gettting failed errors after registering...

    The following error appears after someone registers:
    Warning: failed to connect to mailserver, verify your "SMTP settting in php.ini in C:\Program Files\PHP Home Edition 2\www\forums\register.php on line 517."
    I've located my php.ini and made the following change:
    [mail function]
    SMTP= localhost ; for Win32 only
    sendmail_from= [email protected] ; for Win32 only
    ;sendmail_path=;for unix only, may supply arguments as well (default is 'sendmail -t -i')
    Am I doing something wrong here?
    I understand this may not be related to the product, but I'm hoping I can get some assistance or pointed in the right direction.
    Any response is appreciated...

  • #2
    Are you sure you're running a mailserver on localhost?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      OK...think I'm getting you. I do run a mail server, but it's on another server, mail.nubiint.com. So maybe I should try this instead mail.nubiint.com?
      Last edited by marvc; Fri 23 Aug '02, 12:57pm.

      Comment


      • #4
        Yes, try that. However that server will need to be configured to accept mail from your server.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          OK...ahhh.....configure my server? hmmm...ahhrrmmm
          maybe I need to ask this now before I start bombarding you with a lot questions. Can you point me to a tutorial on how to do this?
          This seems like a process I'd like to document. Currently searching the board.

          Comment


          • #6
            I'm sorry this just dawned on me, but shouldn't vBulletin be set to send mail from the board to registered users? What should I have to configure?

            Comment


            • #7
              vB uses PHP's mail() function. You need to configure PHP properly first for vB email to work.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I'm still having a problem with my board not sending activation mail to the users. I'm now getting the following error after a user submits the registration form:
                Warning: Server Error in C:\Program Files\php Home Edition 2\www\forums\register.php on line 517.

                I run the mail test and it tells me:
                Mail sent. Were any errors shown? If there were, mail is probably not set up correctly.
                There are no errors shown.
                If I send this to an external user, yahoo or hotmail, they don't get the test mail.
                Can someone pleeease advise me on what's going wrong here???

                Any response is appreciated...

                Comment


                • #9
                  Backup your database, then run this MySQL query in phpMyAdmin:

                  UPDATE template SET template = REPLACE(template, "\n", "\r\n");
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    ok...after staring at this for about 25 minutes I have to admin that I don't have a clue on where to add this? I mean I can navigate to phpMyadmin, select the vBulletin db, and click on the Query tab. Afterwards its all "NEW". Am I asking for a drop-kick by asking for some assistance on how to add this??? The only good thing is that I'm documenting this and won't have to ask again...

                    Comment


                    • #11
                      You enter this in the query box.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        I enter that into the box and select "update query" and I get Database vBulletin running on localhost". I'm not sure what I should be looking for.
                        If I enter and click "submit query" it tells me I need to select at least one column to display.

                        Comment


                        • #13
                          What version of phpMyAdmin is this? I don't see those options on mine. You need to enter the query in the 'Run SQL query/queries' box, then press the 'GO' button.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            phpinfo states that it's ver4.2.2-dev.

                            Comment


                            • #15
                              That's your PHP version, not your phpMyAdmin version. Besides, didn't you say that nubiint.com was a different server than the one where you are running your forums?

                              I do run a mail server, but it's on another server, mail.nubiint.com.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X