Announcement

Collapse
No announcement yet.

php and sql versions / best perfoming version with vB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • php and sql versions / best perfoming version with vB

    WordPress is changing their php and sql minimum version requirements for all future WP versions. PHP version 5.2.4 or greater and MySQL version 5.0.15 or greater.

    would this have any adverse effects on my vB software on my server if i was to upgrade to the most current versions of both mentioned.


    thanks

  • #2
    No, vBulletin 4 requires php 5.2.0 and MySQL 4.1.0, it runs fine on newer versionas well.

    Comment


    • #3
      upgrade went smooth, getting a few of these errors in admin/maintenance/repair-optimize tables -- "
      contenttype Check Status: OK
      searchcore Check Status: OK
      searchgroup Check Status: OK
      searchlog Check Error: Table upgrade required. Please do "REPAIR TABLE `searchlog`" or dump/reload to fix it!
      searchlog
      tag Check Error: Table upgrade required. Please do "REPAIR TABLE `tag`" or dump/reload to fix it!
      tag
      tagcontent Check Status: OK


      the following have 12MB overheads:
      tag 16.0 KB 32.0 KB 12.00 MB Yes
      tagcontent 48.0 KB 48.0 KB 12.00 MB Yes
      searchcore 128.0 KB 320.0 KB 12.00 MB Yes
      searchgroup 64.0 KB 48.0 KB 12.00 MB Yes
      searchlog 16.0 KB 48.0 KB 12.00 MB Yes
      contenttype 16.0 KB 16.0 KB 12.00 MB Yes


      how do i fix this ? thanks so much

      Comment


      • #4
        They're INNODB tables, that is not overhead, but the total usage of all innodb tables on your server.

        Comment


        • #5
          ok so nothing is wrong there? how about the error messages on the first part of that post,

          errors in admin/maintenance/repair-optimize tables -- "
          contenttype Check Status: OK
          searchcore Check Status: OK
          searchgroup Check Status: OK
          searchlog Check Error: Table upgrade required. Please do "REPAIR TABLE `searchlog`" or dump/reload to fix it!
          searchlog
          tag Check Error: Table upgrade required. Please do "REPAIR TABLE `tag`" or dump/reload to fix it!
          tag
          tagcontent Check Status: OK

          Comment


          • #6
            That is something that you need to do on mysql's end, your tables didn't get upgraded.

            Comment


            • #7
              If you have cpanel, go to MYSQL databases section and apply "REPAIR" on the database.

              Comment


              • #8
                If they're innodb tables, a standard repair wont work.

                Comment


                • #9
                  A couple of issues

                  With table upgrade required errors - you didn't follow the proper mysql upgrade procedure outlined in mysql docs see http://dev.mysql.com/doc/refman/5.1/...us-series.html for MySQL 5.1.x upgrades or http://dev.mysql.com/doc/refman/5.5/...wngrading.html for MySQL 5.5.x upgrades. I'm guessing missing mysql_upgrade run part.

                  InnoDB tables overhead out of the box works differently from MyISAM tables. Read about InnoDB tables in vB4 and how you can convert them back to MyISAM tables for optimize to work at http://vbtechsupport.com/675/
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X