Announcement

Collapse
No announcement yet.

vBulleting fully compatible with php4.1.0?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulleting fully compatible with php4.1.0?

    Hi,

    I've read the discussion re.php4.1.0 - just wondering if vBulleting can confirm that the actual vBulletin code is fully compliant with 4.1.0 standards? Running Win2k, and so very keen to upgrade as soon as possible, but without risking my forums.

    Any chance of announcement on this?

    Ross

  • #2
    I've been running vB with PHP 4.1 on Win2k with IIS 5 with no problem except I had to turn off persistant connections or I would get a warning on every page.

    It went pretty smooth too.
    Chen Avinadav
    Better to remain silent and be thought a fool than to speak out and remove all doubt.

    גם אני מאוכזב מסיקור תחרות לתור מוטור של NRG הרשת ע"י מעריב

    Comment


    • #3
      Persistant Connections

      Hokay, sounds good.

      Where does one switch on/off persistant connections?

      Comment


      • #4
        In your config.php, set $usepconnect to 0.
        Chen Avinadav
        Better to remain silent and be thought a fool than to speak out and remove all doubt.

        גם אני מאוכזב מסיקור תחרות לתור מוטור של NRG הרשת ע"י מעריב

        Comment


        • #5
          We can not guarantee that there are no problems with v4.1.0 since it just came out. We would suggest you do not upgrade as soon as new versions of PHP are released unless you are prepared to deal with potential problems. If we receive any bug reports we will look into it and post viable fixes as needed.

          Comment


          • #6
            I got bored and changed all the global variables set by php like $HTTP_POST_VARS to $_POST and $HTTP_COOKIE_VARS to $_COOKIE

            but i just realised now that my board will only run on php 4.1.0 silly me lol
            Scott MacVicar

            My Blog | Twitter

            Comment


            • #7
              Since I tried to install this version of php and got this error, I uninstalled it to revert back to the older version and I've been having all sorts of problems; users not being able to register, new posts are lost, "mark forums as read" not working, etc...!
              I'm not sure what's happened. Should I uninstall the old version before installing this one?

              No I've installed it again and turned pers. con. off with no error message but the problems still prevail!

              Comment


              • #8
                mam14: Sounds like problems with some parameters in php.ini
                Are you still using the old one from before you installed 4.1.0?
                MCP / MCSA / MCSE / MCT
                A few eggs short of a complete easter basket

                vB 4.0.5+ CMS (No hacks), Windows Server 2008 R2 Ent, IIS 7.5, PHP 5.3+ (FastCGI), WinCache, Memcached, MySQL 5.1.45

                Comment


                • #9
                  Originally posted by mam14
                  Since I tried to install this version of php and got this error, I uninstalled it to revert back to the older version and I've been having all sorts of problems; users not being able to register, new posts are lost, "mark forums as read" not working, etc...!
                  I'm not sure what's happened. Should I uninstall the old version before installing this one?

                  No I've installed it again and turned pers. con. off with no error message but the problems still prevail!
                  Please enter your vBulletin.com forum username on the form on this page to receive support for this issue: http://www.vbulletin.com/members/forums.php
                  - you will need your vB license customer number and password to access this form.
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X