Announcement

Collapse
No announcement yet.

I have a strange line in my header

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TexasChopper
    replied
    IY IY IY!!! I have alot of work to do. Thanks for looking eveything over, and informing me of the problems

    Leave a comment:


  • Lynne
    replied
    I'm not seeing any line between the images (I'm using firefox 3.5.2), but I'm guessing issue 1 below is causing them. However, I do see several things wrong:

    1. You aren't closing your <a> tags.
    For instance, this:
    HTML Code:
    <a href="http://www.citywidemagazine.com/index.php?option=com_content&view=article&id=50&Itemid=27">
    <img src="http://citywidemagazine.com/forum/images/headlines.png" border="0" width="150" height="40">
    Should be (note the </a> at the end):
    HTML Code:
    <a href="http://www.citywidemagazine.com/index.php?option=com_content&view=article&id=50&Itemid=27">
    <img src="http://citywidemagazine.com/forum/images/headlines.png" border="0" width="150" height="40"> </a>
    2. Your image tag in this line is wrong:
    HTML Code:
    <a  href="http://www.citymagazine.com/forum"><imgsrc="http://citywidemagazine.com/forum/images/forumhome.png" border="0" width="150" height="40">
    Change to:
    HTML Code:
    <a href="http://www.citymagazine.com/forum"><img src="http://citywidemagazine.com/forum/images/forumhome.png" border="0" width="150" height="40"></a>
    3. And, all image tags should have an alt field in them and a / at the end, like this:
    HTML Code:
    <img src="http://citywidemagazine.com/forum/images/forumhome.png" border="0" width="150" height="40" alt="forumhome" />
    4. You forgot an end quote in this line:
    HTML Code:
    <a href="http://www.citywidemagazine.com style="text-decoration: none;">
    Should be (I'm removing the style since I don't think that is the issue any longer):
    HTML Code:
    <a href="http://www.citywidemagazine.com">

    Leave a comment:


  • TexasChopper
    replied
    http://www.
    Last edited by TexasChopper; Tue 11 Aug '09, 3:29pm.

    Leave a comment:


  • Lynne
    replied
    Can we get a link to see what is going on?

    Leave a comment:


  • TexasChopper
    replied
    I see. I actually removed all the spaces, but it's still showing one small _ between the images

    Leave a comment:


  • Lynne
    replied
    No. I was saying it was the space that was causing the problem - the &nbsp; that you say you have in there. They are getting underlined because of the link you have around the image. You need to add the text-decoration:none to the link tags that surround your image in order for the space to not be underlined. <ahref ... will not work.

    Leave a comment:


  • TexasChopper
    replied
    so it now reads...

    <a href=mywebsite.com style="text-decoration: none;" >

    that did not rid me of the line. If this makes a difference I had the buton images spaced using &nbsp if I were to put say 10 of those spaces in place it would increase the line that amount as well. The line comes in front of the image.

    as far as the space you mentioned in the prior post I changed <a href to <ahref I assume that is what you were referring to? Thanks

    Leave a comment:


  • Lynne
    replied
    Originally posted by TexasChopper View Post
    and where exactly would I place this info?

    tag: style="text-decoration: none;"
    In your <a> tag - the link tag - <a href="whatever" style="text-decoration: none;" >

    Leave a comment:


  • TexasChopper
    replied
    and where exactly would I place this info?

    tag: style="text-decoration: none;"

    Leave a comment:


  • Lynne
    replied
    I could be the space before the image. You should add this to your link (<a>) tag: style="text-decoration: none;"

    Leave a comment:


  • TexasChopper
    started a topic I have a strange line in my header

    I have a strange line in my header

    I have created custom nav button images that I have placed under my header going left to right. I am getting a line between the images I am trying to get rid of.

    example _ [my image] _ [my image] etc.

    The line is connected to the image and also has linking capabilities to the same place that the image behind it links.

    Thanks

    here is my code... the main header and one of the button images

    href="http://www.mysite.com"> <img src="http://www.mysite.com/forum/images/CWMheaderNight.jpg" border="0" width="1525" height="230">
    <br />

    <a href="http://www.mysite.com">
    <img src="http://mysite.com/forum/images/HOME.png" border="0" width="100" height="40">
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X