Announcement

Collapse
No announcement yet.

--Hex-Blob?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • --Hex-Blob?

    I am trying to backup my 3.5.4 board's MySQL (version 4.1.20) using SSH.

    Using the regular

    mysqldump --opt -Q -u dbusername -p databasename > /path/to/backupname.sql

    I was able to backup MySQL to the directory I wanted fine. However, the backup was only 229 megs on the server, when I know the full MySQL database is 429 megs.

    Since we recently upgraded our MySQL & PHP versions to MySQL 4.1.20 and PHP 4.3.9 specifically so we could upgrade to vB 3.6 read Ianomed's post about --Hex-Blob on MySQL 4.1.8+.

    Ianomed <xananda at gmail dot com>Apr 20th '05, 11:11amIf you run MySQL 4.0.23+ or 4.1.8+ you best supply the switch --hex-blob as well. Otherwise if you have thumbnails, attachments and/or avatars stored in the database, you may run into problems restoring these in-tact. These MySQL versions of course also apply on restoring, or the hexadecimal encoded binary fields won't be understood.

    See http://dev.mysql.com/doc/mysql/en/mysqldump.html for additional details.
    I assume my missing 200 megs has something to do with --hex-blob .

    However I am not quite sure where to put --hex-blob in the mysqldump command, and I've tried almost combo I can think of.

    1st) Do you think that --hex-blob is the likely cause of my missing 200megs?

    2nd) If --hex-blob is the problem, could someone help me correct my mysqldump command as the use the --hex-blob syntax correctly?

    (Current example : mysqldump --opt -Q -u dbname -p mywebsite_com_-_vb-mysql >
    /var/www/vhost/mysite.com/wwwdoc/mysite_com_-_vb-bckup.sql )

    Thanks in advance.

    ~Fin
    Last edited by The Finman; Fri 18th Aug '06, 3:18pm.

  • #2
    Nevermind, I found my error.

    Anyone else having trouble try this.

    mysqldump --hex-blob -u dbname -p dbname >
    /path/backupname.sql


    Hmmmmm...however that backup is only 230mgs...I still am missing about 199mgs, and ideas about the discrepency between the MySQL backup via SSH and the MySQL Export via PhpMyAdmin?

    Comment


    • #3
      You will not need the --hex-blob if you where running vB 3.5.4. This version already store attachment data as BLOB's.

      To see if your backup is complete, check the last few lines in the backup file, it should end with entries for the word table.

      Did you maybe recently move attachments or avatars to the filesystem, as this could explain the smaller backup.
      Want to take your board beyond the standard vBulletin features?
      Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

      Comment


      • #4
        Originally posted by Marco van Herwaarden View Post
        You will not need the --hex-blob if you where running vB 3.5.4. This version already store attachment data as BLOB's.

        To see if your backup is complete, check the last few lines in the backup file, it should end with entries for the word table.

        Did you maybe recently move attachments or avatars to the filesystem, as this could explain the smaller backup.
        Thanks Marco.

        This is what is at the end of the backup file.

        UNLOCK TABLES;
        /*!40000 ALTER TABLE `word` ENABLE KEYS */;
        /*!40101 SET SQL_MODE=@OLD_SQL_MODE */;
        /*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;
        /*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;
        /*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
        /*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
        /*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
        /*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;
        I looked at the database in PhpMyAdmin and the last table was post_parsed...but I realized that I had accidently refreshed my SSH screen during the restore process.

        I redid the restore process and checked the last table and it now ends with word, so at least all the tables seem to be there.

        And no, I hadn't moved any attachments or avatars. I just recently converted our 10,000+ member UBB to vBulletin about 3 weeks ago. We also changed hosts last week after one of the most aggrivating experiences I have ever had with our old host.

        I'm going to test the backup and see if it's working.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X