Announcement

Collapse
No announcement yet.

worried

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • worried

    I'm worried about upgrading to vB3


  • #2
    It's because of the hacks right?

    If so, ask your members whether they could do without the hacks for a bit

    I suggest that you test out vB 3 privately before considering to upgrade.

    Comment


    • #3
      Why? Is your board hacked a lot? If so, just do a backup of the database via phpMyAdmin, install a fresh copy of vBulletin v3 and then restore the database. Unless that method has changed in vB3.

      Comment


      • #4
        Will the vB 2 hacks work with vB 3 then?

        Comment


        • #5
          No, all new code
          Running vB since 4-14-2002

          Comment


          • #6
            Originally posted by Joe Page
            Will the vB 2 hacks work with vB 3 then?
            I doubt it but keep in mind that vB3 has a lot of stock features that were hacks in vB2.

            Comment


            • #7
              I worry about the hack some tables got altered and stuff and if I import the current database into a fresh vB3 install it will have messed up tables

              Comment


              • #8
                Originally posted by Andrew111888
                I worry about the hack some tables got altered and stuff and if I import the current database into a fresh vB3 install it will have messed up tables
                There is a script in the announcement forum that detects potential database conflicts so you don't have to worry about that.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API

                Comment


                • #9
                  Originally posted by Andrew111888
                  I worry about the hack some tables got altered and stuff and if I import the current database into a fresh vB3 install it will have messed up tables
                  There are significant changes to the database in vB3. You would not be able to "import" a vB2 database. It will have to be upgraded.
                  Create a copy of your live database and test the upgrade on it prior to going live with it if you're worried about changes
                  Webmaster:
                  @forumz

                  Comment


                  • #10
                    Originally posted by Martin
                    There are significant changes to the database in vB3. You would not be able to "import" a vB2 database. It will have to be upgraded.
                    Create a copy of your live database and test the upgrade on it prior to going live with it if you're worried about changes
                    I stand corrected then.

                    Comment


                    • #11
                      Thanks for the info guys I'll customize it in private then backup those templates and upgrade my board for it.

                      Wayne, does that script fix the conflicts, too?

                      Comment


                      • #12
                        No it doesn't. If you read the annoucement in the annoucement forum it'll tell you what to do if there is a conflict.

                        Comment


                        • #13
                          Originally posted by Andrew111888
                          Thanks for the info guys I'll customize it in private then backup those templates and upgrade my board for it.

                          Wayne, does that script fix the conflicts, too?
                          Nope, the script makes not changes, it informs you of any duplicate tables/columns.

                          *edit, Cary barley beat me
                          Webmaster / Administrator
                          www.MegaGames.com
                          www.MGForums.com

                          Comment


                          • #14
                            Originally posted by Joe Page
                            It's because of the hacks right?

                            If so, ask your members whether they could do without the hacks for a bit

                            I suggest that you test out vB 3 privately before considering to upgrade.
                            I didn't bother asking my members whether they could deal without the hacks, think about it, we're the bosses/admins, so I just decided they will deal without them

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X