Announcement

Collapse
No announcement yet.

upgrading from vb2 to vb3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgrading from vb2 to vb3

    Go and upgrade! This release includes important fixes for everyone, and we would recommend that you upgrade as soon as possible. vBulletin 3 is on its way, so keep your eyes peeled on this forum. However, you will only be able to upgrade to vB 3.0 from the latest version of vB 2.2.x so we would recommend that you upgrade to this version for the time being.

    right now, would a hacked vB2, returned to semi-normal, including orginal files replaced, have much of an issue upgrading?

  • #2
    its not really the files that matter its how hacked is your database schema.

    Have you removed any vBulletin columns or tables? If so it should be smooth though you may have problems and lose data as i believe the upgrade script drops some tables and recreates them.

    I upgraded my board on a beta site with 105,000 posts went quite smoothly.
    Scott MacVicar

    My Blog | Twitter

    Comment


    • #3
      ah ok, never deleted any tables, whew

      Comment


      • #4
        Originally posted by PPN
        its not really the files that matter its how hacked is your database schema.

        Have you removed any vBulletin columns or tables? If so it should be smooth though you may have problems and lose data as i believe the upgrade script drops some tables and recreates them.

        I upgraded my board on a beta site with 105,000 posts went quite smoothly.

        would that mean someone running 2.2.5 or 2.2.6 sould upgrade to 2.2.8 before going to 3.0 later this year? the only reason i ask is that 2.2.7 and 2.2.8 have some db schema changes.

        Comment


        • #5
          Right; as I understand it the upgrader would not care at all what PHP files exist and no matter how hacked they are, but just what's in the raw database. If you close the board you can probably just run the upgrade scripts without even replacing the files, then directly run the 3.0.0 importer.
          --filburt1, vBulletin.org/vBulletinTemplates.com moderator
          Web Design Forums.net: vB Board of the Month
          vBulletin Mail System (vBMS): webmail for your forum users

          Comment


          • #6
            Originally posted by Anime-loo
            would that mean someone running 2.2.5 or 2.2.6 sould upgrade to 2.2.8 before going to 3.0 later this year? the only reason i ask is that 2.2.7 and 2.2.8 have some db schema changes.
            You will have to upgrade to the latest version of 2.2.X in order to run the VB 3.0 upgrade scripts. There is no way around that as the upgrade will rely on the latest database schema.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment


            • #7
              Originally posted by PPN
              Have you removed any vBulletin columns or tables? If so it should be smooth though you may have problems and lose data as i believe the upgrade script drops some tables and recreates them.
              I haven't deleted any, but I have added some in. Would that be a problem? Or would the upgrade script just ignore them and continue on?

              Comment


              • #8
                Originally posted by Wayne Luke
                You will have to upgrade to the latest version of 2.2.X in order to run the VB 3.0 upgrade scripts. There is no way around that as the upgrade will rely on the latest database schema.
                Thanks for the reply!


                Have you removed any vBulletin columns or tables? If so it should be smooth though you may have problems and lose data as i believe the upgrade script drops some tables and recreates them.
                ive added many and deleated a row here are there. PPN ive installed your attachments as files hack and im wondering how i can upgrade to 3.0 with said db modifacation? will you be releasing a upgrade script? and will added tables effect the upgrade to 3.0?

                Comment


                • #9
                  I'll be releasing an updater file for that to change it into the vB3 format
                  Scott MacVicar

                  My Blog | Twitter

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X