Announcement

Collapse
No announcement yet.

More CVS help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • More CVS help

    I've successfully created a repository, I think. My host has ports 2401 and 2402 (CVS and pserver) blocked, so I connect through an SSH tunnel in Eclipse. This means that, to log in, I have to type my account username and password on the server as if I was logging in through a normal SSH client.

    This is a team-based project, I'm the only one on this server, and it's a shared server so I don't have root access. Others need to have read/write access to the files through CVS (i.e., they need to be able to browse the repository and commit files). So, how can I allow remote users to the files while still denying global read/write/execute access to everybody else to everybody except myself and other specific users?
    --filburt1, vBulletin.org/vBulletinTemplates.com moderator
    Web Design Forums.net: vB Board of the Month
    vBulletin Mail System (vBMS): webmail for your forum users

  • #2
    I suspect you've worked this out already, but the CVS book I have recommends creating a CVS group and giving it ownership of the repository, then making anyone who will be accessing it a member of that group. I'm using Eclipse on WinXP with CVS on a Linux box and that's what I did.

    I also just found out the hard way that you have to use the -kb switch when importing binary files into CVS. That makes it kinda hard to import the whole forum directory given all the images in various places.

    Comment


    • #3
      I did figure it out; I had to connect using extssh, not pserver, and my host created the proper accounts I needed.
      --filburt1, vBulletin.org/vBulletinTemplates.com moderator
      Web Design Forums.net: vB Board of the Month
      vBulletin Mail System (vBMS): webmail for your forum users

      Comment


      • #4
        Ah, that makes sense. Congrats.

        I figured my problem out too. I can use a cvswrappers file to tell CVS to import all files with image extensions as binary files by adding entries like so for each file type:

        *.jpg -k 'b'

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X