Announcement

Collapse
No announcement yet.

Can a PATA be run with a SATA?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can a PATA be run with a SATA?

    I have my primary disk as a 40GB PATA HDD

    I just got a 160GB SATA drive as an early xmas present


    Problem is, it isn't detected

    I've tinkered with the BIOS, and it has one SATA option, it says:

    Standard - boots to PATA but doesnt detect SATA
    For Primary - nothing
    For Secondary - ignores both harddrives and tries to boot from CD Roms
    Enhanced - Buggers the whole PC up



    Did I miss a trick?

  • #2
    Does your motherboard support SATA natively or are you using an add-in card?

    Comment


    • #3
      Did instructions come with whatever your SATA drive is plugged into?

      Comment


      • #4
        Did you enable SATA controllers, via native mode?
        ManagerJosh, Owner of 4 XenForo Licenses, 1 vBulletin Legacy License, 1 Internet Brands Suite License
        Director, WorldSims.org | Gaming Hosting Administrator, SimGames.net, Urban Online Entertainment

        Comment


        • #5
          If your SATA controller is also a raid controler, you may have to set up a raid array through the raid setup. If you only have one SATA drive, you can setup a raid0 with a signle drive.
          Mike Warner
          MIGWeb - a Vauxhall Site for Enthusiasts of all Vauxhalls

          Comment


          • #6
            You do want enhanced mode, even though it "buggers" the computer up.

            Enhanced mode will allow you to run 4 x PATA devices and 2 X SATA devices. If you use legacy mode, you will lose 2 X PATA devices and the SATA devices will be remapped to the lost PATA. This is for legacy support so that SATA drives will appear as IDE. It's not what you want to do.

            The "buggers it up" problem you might have when switching from Legacy to Enhanced, is that the labeling of the drives may change. This will mean that you might get nasty STOP screens about INACCESSIBLE_BOOT_DEVICE or the boot loader may not be found. You could attempt to fix this once you switch to legacy mode by using fixmbr from the Recovery Console. Otherwise you may need to reinstall Windows on your machine if you cannot find a way to fix your MBR/boot.ini etc

            Hope this helps! I know its' a PITA because I've had so many problems with this in the past myself.
            HP DL-380 G6, 2x E5520, 28GB RAM, 4x300GB SAS, VMWare ESXi
            -
            Unreal Tournament : Assault forums - irc://irc.utassault.net:6667 -

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X