Announcement

Collapse
No announcement yet.

Verschiedener Font Typ bei Adresse mit www. und ohne?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Erledigt] Verschiedener Font Typ bei Adresse mit www. und ohne?

    Hallo liebes Team,

    Ich habe ein Problem dass ich mir nicht erklären kann.
    Ich habe meinen Foren Style angepasst. Wenn ich jetzt meine Foren Adresse mit www. also http://www.kreatives-netzwerk.at aufrufe wird eine andere Font gezeigt als wenn ich die Adresse ohne www. eingebe. Bei zum Beispiel http://kreatives-netzwerk.at wird die Font richtig angezeigt so wie es sein soll.
    Ich habe zwei Bilder mitgesendet damit ihr seht was ich meine.

    http://alexander-lanthaler.at/art-mag.at/mit%20www.png

    http://alexander-lanthaler.at/art-mag.at/ohne%20www.png

    Ich hoffe dass sie mir helfen können.
    Ich finde einfach keine Lösung dafür.

    Mit freundlichen Grüßen
    Last edited by UOM; Tue 8 Dec '20, 2:50am.

  • #2
    Als aller erstes solltest Du mal ssl einschalten und alle domains zu https:// weiterleiten.
    Dann solltes Du auch die www. Seite zu der ohne www. umleiten, oder umgekehrt....

    Das Problem ist, dass die Dateien für die Schriftart nicht geladen werden können, da die Domain nicht übereinstimmt.

    Kann man zwar umgehen, sollte man aber nicht. Daher am besten meine Vorschläge oben umsetzen und dann sollte es auch funktionieren.

    Gruß

    Comment


    • #3
      Originally posted by delicjous View Post
      Als aller erstes solltest Du mal ssl einschalten und alle domains zu https:// weiterleiten.
      Dann solltes Du auch die www. Seite zu der ohne www. umleiten, oder umgekehrt....

      Das Problem ist, dass die Dateien für die Schriftart nicht geladen werden können, da die Domain nicht übereinstimmt.

      Kann man zwar umgehen, sollte man aber nicht. Daher am besten meine Vorschläge oben umsetzen und dann sollte es auch funktionieren.

      Gruß
      Hallo und vielen Dank für die schnelle Antwort,

      Wie binde ich ein SSL Zertifikat in Vbulletin 5 ein?
      Last edited by UOM; Mon 7 Dec '20, 10:52am. Reason: ssl

      Comment


      • #4
        Originally posted by delicjous View Post
        Als aller erstes solltest Du mal ssl einschalten und alle domains zu https:// weiterleiten.
        Dann solltes Du auch die www. Seite zu der ohne www. umleiten, oder umgekehrt....

        Das Problem ist, dass die Dateien für die Schriftart nicht geladen werden können, da die Domain nicht übereinstimmt.

        Kann man zwar umgehen, sollte man aber nicht. Daher am besten meine Vorschläge oben umsetzen und dann sollte es auch funktionieren.

        Gruß
        Ich habe nun die Domain auf SSL weitergeleitet!
        Es funktoniert alles sehr gut bis auf das Problem mit den unterschiedlichen Fonts!?

        Comment


        • #5
          Sieht doch ganz gut aus, oder?

          Hast Du die Seite in den vBulletin Einstellungen auch auf http:// geändert? -> (/admincp/options.php?do=options&dogroup=routeurl)

          Comment


          • #6
            Originally posted by delicjous View Post
            Sieht doch ganz gut aus, oder?

            Hast Du die Seite in den vBulletin Einstellungen auch auf http:// geändert? -> (/admincp/options.php?do=options&dogroup=routeurl)
            Nein ich habe die Einstellungen auf https
            ich habe folgendes als antwort bekommen:

            ...and edit the URLs to read https instead of http. You should also remove the comments from the two lines in the .htaccess files which will force all traffic to use https.
            Ich weiß leider nicht was ich machen muss?
            Last edited by UOM; Tue 8 Dec '20, 12:00am.

            Comment


            • #7
              In deinem Forum-Root auf dem FTP gibt es eine Datei .htacces . In dieser musst Du die # vor den 2 Zeilen entfernen.

              Vorher:

              Code:
              #To redirect users to the secure version of your site, uncomment the lines below
              #RewriteCond %{HTTPS} !=on
              #RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
              Nacher:

              Code:
              #To redirect users to the secure version of your site, uncomment the lines below
              RewriteCond %{HTTPS} !=on
              RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
              Aber aufpassen das sonst nichts geändert wird.

              Comment


              • #8
                Originally posted by delicjous View Post
                In deinem Forum-Root auf dem FTP gibt es eine Datei .htacces . In dieser musst Du die # vor den 2 Zeilen entfernen.

                Vorher:

                Code:
                #To redirect users to the secure version of your site, uncomment the lines below
                #RewriteCond %{HTTPS} !=on
                #RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
                Nacher:

                Code:
                #To redirect users to the secure version of your site, uncomment the lines below
                RewriteCond %{HTTPS} !=on
                RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
                Aber aufpassen das sonst nichts geändert wird.
                Ok alles erledigt!
                Aber die Font wird trotzdem noch unterschiedlich angezeigt!?
                Mit www. und ohne www. wird die Schrift anders angezeigt.

                Comment


                • #9
                  Dann kommentiere die Zeilen wieder (muss so aussehen wie im Code Vorher) und füge darunter folgendes ein:


                  Code:
                  RewriteCond %{HTTPS} off [OR]
                  RewriteCond %{HTTP_HOST} ^www\. [NC]
                  RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
                  RewriteRule ^ https://%1%{REQUEST_URI} [L,NE,R=301]
                  Das sollte alle Seiten zu der Version ohne www. weiterleiten.

                  Comment


                  • #10
                    Originally posted by delicjous View Post
                    Dann kommentiere die Zeilen wieder (muss so aussehen wie im Code Vorher) und füge darunter folgendes ein:


                    Code:
                    RewriteCond %{HTTPS} off [OR]
                    RewriteCond %{HTTP_HOST} ^www\. [NC]
                    RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
                    RewriteRule ^ https://%1%{REQUEST_URI} [L,NE,R=301]
                    Das sollte alle Seiten zu der Version ohne www. weiterleiten.
                    Yeah Vielen Dank!
                    Endlich funktioniert es so wie es soll.

                    Danke nochmals für den Super Support

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X