Announcement

Collapse
No announcement yet.

Keine deutschen Sonderzeichen (äöüß) in Kommentaren seit Upgrade 5.1.8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Keine deutschen Sonderzeichen (äöüß) in Kommentaren seit Upgrade 5.1.8

    Seit dem Upgrade auf 5.1.8 sind Kommentare, die deutsche Sonderzeichen enthalten (äöüß) in meinem Forum fehlerhaft.

    Wenn ich versuche, einen Kommentar mit einem Sonderzeichen zu posten, bekomme ich die Fehlermeldung

    Error: Text required
    Auch Anführungszeichen im Kommentar "" werden durch " ersetzt.

    Hat jemand das gleiche Problem oder Ideen, es zu lösen?

  • #2
    Ich habe das gerade mal ausprobiert. Bei den Umlauten bzw. dem ß gibt es keine Probleme (die werden korrekt dargestellt), allerdings habe ich ebenfalls das " in den Kommentaren, wenn ich dort Anführungszeichen verwende. Gab es das Problem nicht auch mal in Thementiteln? Vielleicht hat das ja die gleiche Ursache.

    Edit: Letzteres ist ein bekannter Bug (VBV-14916).
    Last edited by TLMD; Tue 18 Aug '15, 3:10am.

    Comment


    • #3
      Noch ein paar Infos:

      Wenn ich ein Kommentar bearbeite, und einen Umlaut od. ß hinzufüge, ist das Kommentar nach dem Speichern noch da, aber der komplette Text verschwunden.
      Das Eingabefeld für den Grund der Bearbeitung hat das Problem nicht, dort können Umlaute und ß problemlos verwendet werden.

      Comment


      • #4
        Sehr merkwürdig, bei mir passiert das nicht. Ich konnte nur diesen JIRA-Eintrag (VBV-12093) finden, der nicht direkt dein Problem beschreibt, aber wenn es stimmt, dass der CKEditor-Code nicht immer korrekt geladen wird (zweiter Kommentar in dem JIRA-Eintrag), dann trifft das vielleicht auch auf deine vB-Installation zu?

        Ansonsten: hAst du das Problem nur bei einer bestimmten vB-Installation? Was ist mit einer (Test-)Installation -- tritt der Fehler dort auch bei dir auf?

        Comment


        • wurfgang
          wurfgang commented
          Editing a comment
          Ich habe leider nur die eine vB-Installation.

      • #5
        Dieser Fehler ist bei mir noch immer aktuell, nutze vBulletin 5.1.9 (5.2.0 ist der Fehler noch immer da).
        Alles Liebe,
        Eisu

        Comment


        • #6
          Frohen Mutes zu hohen Zielen wandeln. Die Amis haben es nicht so mit Umlauten. Der Fehler taucht immer wieder auf. Auch im Zusammenhang mit Modulen und da mit dem Titel.

          Comment


          • #7
            tyreco Konntest Du das Umlautproblem in den Kommentaren (Pinnwand, Artikel, Blog usw.) lösen?
            Alles Liebe,
            Eisu

            Comment


            • #8
              Nein, selbst wenn es bei einer Version "mal" funktioniert wird es in der nächsten wieder buggy sein. Deshalb schrieb ich ja: Frohen Mutes zu hohen Zielen wandeln.

              Ich warte händeringend darauf dass einer der vb Proggis mal an die Tanke fährt und fuffzisch Liter tankt. Wir werden allerdings nur 25 reinlaufen lassen aber voll kassieren. Für die fehlenden 25 Liter soll er dann hier http://tracker.vbulletin.com/secure/Dashboard.jspa einen Bug melden und sich vorher registrieren. Es wird dann an einem der nachfollgenden Tankvorgänge gefixt. Wir wissen allerdings noch nicht wann.

              Das steht auf meinem Wunschzettel ganz oben, bold und in rot.

              Comment


              • #9
                Rein interessehalber: Nutzt ihr eigentlich Neuinstallationen, wenn ihr von diesem Fehler sprecht, oder sind das Upgrades, die sich über die Zeit angesammelt haben und die ursprüngliche Installation war mal ein vB 5.0.0 (oder ähnlich alt)?

                Comment


                • #10
                  Ich nutze vBulletin seit 2007, seither mache ich Updates / Upgrades
                  Damals bin ich mit vBulletin 3.6 gestartet, hatte Styles und auch das CMS von vBDesigns, viele externe Add-Ons wie Blog, Projecttools usw.

                  Diesen Umlautfehler konnte ich aktuell bannen, indem ich die Datenbank auf UTF-8 konvertiert habe.
                  Alles Liebe,
                  Eisu

                  Comment


                  • #11
                    Wie haben eine Neuinstallation und eine von 4.2.3 upgedatete. Letzere hatte ich schon auf UTF-8 konvertiert.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X