Announcement

Collapse
No announcement yet.

Anmelden mit www und ohne www.forumname.de > 5.13

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Erledigt] Anmelden mit www und ohne www.forumname.de > 5.13

    Ich möchte dass eine Anmeldung mit

    http://forumname.de
    und
    http://www.forumname.de

    möglich ist. Welche Settings muss ich vornehmen?

    Im Moment habe ich bei den URL Einstellungen http://www.forumname.de eingesetzt und so ist eine Anmeldung unter http://forumname.de nicht möglich.
    Last edited by tyreco; Fri 7 Nov '14, 7:47am.

  • #2
    Mal eine blöde Frage meinerseits, weil sie an dieser Stelle ganz gut passt: Ist es mittlerweile nicht völlig egal, was man im Browser eingibt?

    Ich verweise beispielsweise in meiner vB5-Installation auf http://forumname.de (also ohne www davor), aber wenn ich im Browser die Varianten ohne und mit www eingebe, dann lande ich in beiden Fällen auf der Seite. Ich schätze also, dass das www "wie auch jede andere 3rd Level Domain erkannt" und daher auch "automatisch auf die Hauptseite verwiesen wird", wenn man das www weglässt. (Sorry für die untechnische Formulierung.)

    Ach ja, zu deiner Frage: Versuche mal die Variante ohne www in die URL-Einstellungen einzutragen. Wie gesagt, bei mir funktioniert das ohne Probleme.

    Comment


  • #3
    Merkwürdig, ich habe es gerade noch einmal ausprobiert und auch die Anmeldung funktioniert bei mir in beiden Fällen (also mit und ohne www in der Adresszeile). Da bin ich mal neugierig, was andere zu deinem Problem sagen, denn woran es genau liegt, das interessiert mich dann auch.

    Comment


    • #4
      Bei mir funktioniert es auch mit oder ohne www.
      Steht bei Forum-URL und Login-URL die selbe Adresse?

      Comment


      • #5
        Ja, in Forum URL steht das Gleiche wie in Login URL: http://www.meinedomain.de

        Es muss eine Weiterleitung in der .htaccess definiert werden die meinedomain.de auf www.meinedomain.de leitet. Dann geht es.

        RewriteCond %{HTTP_HOST} ^meinedomain\.de$
        RewriteRule (.*) http://www.meinedomain.de/$1 [R=301,L]

        Die Weiterleitung hatte ich bei unserer 4.2.x nicht. Bei der 5.1.3 habe ich nach Tip des Ticket Supports in der .htaccess gelöst.
        Bin nicht der Profi und habe mir im Internet diverse Schreibweisen rausgesucht. Bei vielen kam nach Aufruf der .htaccess der Hinweis auf zu viele Weiterleitungen. Mit der oben beschriebenen funktioniert es nun.


        Comment


        • #6
          Ihr solltet euch generell überlegen, ob ihr eure Seite mit oder ohne www aufrufen wollte und dann je nach Entscheidung eine Regel in der htaccess einfügen die zur jeweiligen Wunschurl weiterleitet.
          Denn für Google sind Links mit www und ohne www jeweils zwei verschiedene URLs und somit hättet ihr Duplicate Content.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X