Announcement

Collapse
No announcement yet.

vb5 -> Rewriteengine funktioniert nicht auf localhost xampp

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vb5 -> Rewriteengine funktioniert nicht auf localhost xampp

    Hallo zusammen,

    ich entwickle gerade ein Portal mit Drupal, dessen Herzstück ein vbulletin5 Diskussionsforum ist. Das Board selber ist unter meinedomain.de/vb5/ erreichbar. Auf dem Webserver funktioniert alles prima, aber nicht auf dem xampp. Da scheint das rewriting nicht zu funktionieren. Aber der Reihe nach.

    So sieht die htaccess aus.

    Code:
    <IfModule mod_rewrite.c>
        Options +FollowSymLinks
         RewriteEngine On
        
         #In some cases where you have other mod_rewrite rules, you may need to comment out the following line
         #and change it to match your folder name. This resets the other mod_rewrite rules for just this directory
         #If your site was www.example.com/forum, the setting would be /forum/
         RewriteBase /vb5/
    
         # Send css calls directly to the correct file VBV-7807
         RewriteRule ^css.php$ core/css.php [NC,L]
    
         # Main Redirect
         RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
         RewriteCond %{REQUEST_FILENAME} !-f
         RewriteCond %{REQUEST_FILENAME} !-d
         RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]
    
         # Because admincp is an actual directory.
         RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]
    ...
    ...
    Mein lokaler Xampp lässt sich als vhost über develop.dev aufrufen. Das Forum ist über http://develop.dev/vb5 erreichbar, zieht aber z.B. keine Stylesheets.

    Man sieht an der htaccess, dass der Aufruf von http://develop.dev/vb5/css.php die Datei css.php im Unterverzeichnis core ziehen sollte. Das tut es aber nicht. Wie gesagt auf dem Webserver funktioniert mit derselben htaccess alles perfekt.

    Vielleicht als Ergänzung: Auf dem xampp (develop.dev) funktionieren ansonsten rewriterules einwandfrei.

    Jetzt bin ich mit meinem Latein am Ende.

    Bin für jeden Tipp dankbar.

    Viele Grüße rhodes

  • #2
    Hallo,

    hast du in deinen vBulletin-Einstellungen auch angegeben, dass die CSS-Dateien aus dem Dateisystem gelesen werden sollen (anstatt der Datenbank)?

    Comment


    • #3
      Hallo,

      danke für Deine schnelle Antwort.

      Nein, ich habe in den vBulletin-Einstellungen noch gar nichts gemacht, sondern nur die Standard-Installation durchlaufen lassen. Und nach Ende der Installation, die als erfolgreich abgeschlossen gemeldet wird, sehe ich nur Kraut ud Rüben wg. fehlender Style-Sheets. Bis zum Admin cp komme ich auch gar nicht, weil die Rewrites nicht funktionieren.

      VG rhodes

      Comment


      • #4
        Hy,

        wenn das Forum auf deinem Server im Verzeichnis vb5 liegt und du die selbe htaccess-Datei verwendest, müsstest du lokal auch das Verzeichnis /vb5/ verwenden.

        Comment


        • #5
          Hi,

          das tue ich auch. Sowohl auf dem Server, als auch auf dem localhost liegt das Forum in VB5. In der htacces ist in beiden Fällen als RewriteBase /vb5/ definiert.

          VG rhodes

          Comment


          • #6
            Hallo,

            ich kann dir vlt noch folgende zwei Links anbieten:
            http://stackoverflow.com/questions/1...ost-with-xampp
            http://www.lancelhoff.com/enabling-h...he-on-windows/

            Comment

            Related Topics

            Collapse

            Working...
            X