Announcement

Collapse
No announcement yet.

"Wings" in Showthread template

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Wings" in Showthread template

    http://www.debatela.com/forum/showth...hp?threadid=10

    As you can see, there are gray (tablebordercolor and pagebackgroundcolor) "wings" encompassing the table that shows the thread. How do I get rid of this?

    Thanks!

    jEd

    {htmldoctype}
    <html>
    <head><title>$bbtitle - $thread[title]</title>
    $headinclude
    <script language="javascript" type="text/javascript">
    <!--
    function aimwindow(aimid) {
    window.open("member.php?s=$session[sessionhash]&action=aimmessage&aim="+aimid,"_blank","toolbar=no,location=no,menubar=no,scrollbars=no,w idth=175,height=275,resizeable=yes,status=no")

    }
    // -->
    </script>
    </head>
    <body>
    $header
    <!-- breadcrumb, nav links -->
    <table cellpadding="2" cellspacing="0" border="0" width="{contenttablewidth}" {tableinvisibleextra} align="center">
    <tr>
    <td>$navbar</td>
    $ratingdisplay
    </tr>
    </table>
    <!-- /breadcrumb, nav links -->
    <a name="posttop"></a>
    $poll
    <!-- first unread and next/prev -->
    <table cellpadding="2" cellspacing="0" border="0" width="{contenttablewidth}" {tableinvisibleextra} align="center">
    <tr>
    <td><smallfont>$pagenav $firstunread&nbsp;</smallfont></td>
    <td align="right"><smallfont>
    <img src="{imagesfolder}/prev.gif" alt="" border="0">
    <a href="showthread.php?s=$session[sessionhash]&amp;threadid=$threadid&amp;goto=nextoldest">Last Thread</a>
    &nbsp;
    <a href="showthread.php?s=$session[sessionhash]&amp;threadid=$threadid&amp;goto=nextnewest">Next Thread</a>
    <img src="{imagesfolder}/next.gif" alt="" border="0">
    </smallfont></td>
    </tr>
    </table>
    <!-- first unread and next/prev -->
    <table cellpadding="{tableouterborderwidth}" cellspacing="0" border="0" bgcolor="{tablebordercolor}" {tableouterextra} width="{contenttablewidth}" align="center"><tr><td>
    <table cellpadding="4" cellspacing="{tableinnerborderwidth}" border="0" {tableinnerextra} width="100%">
    <tr>
    <td bgcolor="{tableheadbgcolor}" width="175" nowrap><smallfont color="{tableheadtextcolor}" class="thtcolor"><b>Author</b></smallfont></td>
    <td bgcolor="{tableheadbgcolor}" width="100%">
    <!-- Thread nav and post images -->
    <table width="100%" border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td width="100%"><smallfont color="{tableheadtextcolor}" class="thtcolor"><b>Thread</b></smallfont></td>
    <td><a href="newthread.php?s=$session[sessionhash]&amp;action=newthread&amp;forumid=$forum[forumid]"><img src="{newthreadimage}" border="0" alt="Post New Thread"></a></td>
    <td><normalfont>&nbsp;&nbsp;</normalfont></td>
    <td><a href="newreply.php?s=$session[sessionhash]&amp;action=newreply&amp;threadid=$threadid"><img src="$replyclose" border="0" alt="Post A Reply"></a></td>
    </tr>
    </table>
    <!-- /Thread nav and post images -->
    </td>
    </tr>
    </table>
    </td></tr></table>
    $postbits
    <table cellpadding="{tableouterborderwidth}" cellspacing="0" border="0" bgcolor="{tablebordercolor}" {tableouterextra} width="{contenttablewidth}" align="center"><tr><td>
    <table cellpadding="4" cellspacing="{tableinnerborderwidth}" border="0" {tableinnerextra} width="100%">
    <tr>
    <td bgcolor="{tableheadbgcolor}" width="100%">
    <!-- time zone and post buttons -->
    <table border="0" cellspacing="0" cellpadding="0" bgcolor="{tableheadbgcolor}">
    <tr>
    <td width="100%"><smallfont color="{tableheadtextcolor}"><b>$timezone</b></smallfont></td>
    <td><a href="newthread.php?s=$session[sessionhash]&amp;action=newthread&amp;forumid=$forum[forumid]"><img src="{newthreadimage}" border="0" alt="Post New Thread"></a></td>
    <td><normalfont>&nbsp;&nbsp;</normalfont></td>
    <td><a href="newreply.php?s=$session[sessionhash]&amp;action=newreply&amp;threadid=$threadid"><img src="$replyclose" border="0" alt="Post A Reply"></a></td>
    </tr>
    </table>
    <!-- /time zone and post buttons -->
    </td>
    </tr>
    </table>
    </td></tr></table>
    <!-- first unread and next/prev -->
    <table cellpadding="2" cellspacing="0" border="0" width="{contenttablewidth}" {tableinvisibleextra} align="center">
    <tr>
    <td><smallfont>$pagenav&nbsp;</smallfont></td>
    <td align="right"><smallfont>
    <img src="{imagesfolder}/prev.gif" alt="" border="0">
    <a href="showthread.php?s=$session[sessionhash]&amp;threadid=$threadid&amp;goto=nextoldest">Last Thread</a>
    &nbsp;
    <a href="showthread.php?s=$session[sessionhash]&amp;threadid=$threadid&amp;goto=nextnewest">Next Thread</a>
    <img src="{imagesfolder}/next.gif" alt="" border="0">
    </smallfont></td>
    </tr>
    </table>
    <!-- first unread and next/prev -->
    <!-- thread options links -->
    <table cellpadding="{tableouterborderwidth}" cellspacing="0" border="0" bgcolor="{tablebordercolor}" {tableouterextra} align="center"><tr><td>
    <table cellpadding="4" cellspacing="{tableinnerborderwidth}" border="0" {tableinnerextra} width="100%">
    <tr>
    <td bgcolor="{firstaltcolor}" align="center"><smallfont>
    <img src="{imagesfolder}/printer.gif" alt="" border="0" align="absmiddle">
    <a href="printthread.php?s=$session[sessionhash]&amp;threadid=$threadid">Show Printable Version</a> |
    <img src="{imagesfolder}/sendtofriend.gif" alt="" border="0" align="absmiddle">
    <a href="sendtofriend.php?s=$session[sessionhash]&amp;threadid=$threadid">Email this Page</a> |
    <img src="{imagesfolder}/subscribe.gif" alt="" border="0" align="absmiddle">
    <a href="member2.php?s=$session[sessionhash]&amp;action=addsubscription&amp;threadid=$threadid">Subscribe to this Thread</a>
    </smallfont></td>
    </tr>
    </table>
    </td></tr></table>
    <!-- /thread options links -->

    <br>
    <!-- forum jump and rate thread -->
    <table cellpadding="2" cellspacing="0" border="0" width="{contenttablewidth}" {tableinvisibleextra} align="center">
    <tr>
    <td>$forumjump</td>
    <td align="right">$threadrateselect</td>
    </tr>
    </table>
    <!-- /Rate this thread -->
    <br>
    <!-- forum rules and admin links -->
    <table cellpadding="2" cellspacing="0" border="0" width="{contenttablewidth}" {tableinvisibleextra} align="center">
    <tr valign="bottom">
    <td><smallfont><b>Forum Rules:</b>$forumrules</smallfont></td>
    <td align="right">
    $adminoptions
    </td>
    </tr>
    </table>
    <!-- /forum rules and admin links -->
    $footer
    </body>
    </html>

  • #2
    Do you mean the parts i have circled in this screen shot?
    Attached Files

    Comment


    • #3
      i belive its because innter table width isnt at 100% just off the thought of my head

      Comment


      • #4
        That was gonna be my guess if the screenshot was right

        Comment


        • #5
          Where do I change this variable?

          Thanks!
          jEd

          Comment


          • #6
            Log in too your boards ADMIN CP, and scroll down the left till you see a section called STYLES, click modify.

            Then click fonts/colours and scroll down till you see a section saying Inner Table Width

            Change it

            Comment


            • #7
              Main Table Width is 100%

              Content Table Width is 100%

              Outer Border Width is 0

              Inner Border Width is 0

              The other three variables (Outer Table Extra, Inner Table Extra and Invisible Table Extra are all blank. I did try to put width="100%" in all of those parts but it didn't change anything...

              I could find no "Inner Table Width" variable in the Styles section.

              jEd

              Comment


              • #8
                Ok so where is all the code on your 1st post from? Also put it in [ php ] [ /php ] tags instead of quote ones minus the spaces of course

                Comment


                • #9
                  in the post bit im sure theres a little black pic that makes that happen.

                  look for the following code in the postbit.

                  PHP Code:
                  <img width="10" height="1" src="images/space.gif" alt=""
                  and swap it to

                  PHP Code:
                  <img width="0" height="0" src="images/space.gif" alt=""
                  thats the easy way to fix it with out redoing all the postbit tables.

                  Comment


                  • #10
                    Thanks C.Birch! That did it.

                    jEd

                    Comment


                    • #11
                      Originally posted by DB8 Link
                      Thanks C.Birch! That did it.

                      jEd
                      no probs, happy to help.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X