Announcement

Collapse
No announcement yet.

"Report Post | IP: Logged"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Report Post | IP: Logged"

    How do I change the way the link "Report this post to a moderator | IP: Logged" is positioned by default? I want it positioned the way it is on this forum.

    Someone told me I have to modify within the Admin CP, Templates > Modify > Postbit Templates > Postbit template but I don't know how. Or is there a hack for this?

    Any help would be greatly appreciated. Thanks.

  • #2
    Follow that trail in your admin control panel, and in the template editing box, around the middle of it, you should find a line that looks like this:

    <p align="right"><smallfont><a href="report.php?s=$session[sessionhash]&postid=$post[postid]">Report this post to a moderator</a> | $post[iplogged]</smallfont></p>

    See the <p align="right"> part? Remove the align="right" so it looks like this:

    <p><smallfont><a href="report.php?s=$session[sessionhash]&postid=$post[postid]">Report this post to a moderator</a> | $post[iplogged]</smallfont></p>

    And if you'd like to go one step further and make it look exactly like it is here, just change "Report this post to a moderator" to "Report Post", like so:

    <p><smallfont><a href="report.php?s=$session[sessionhash]&postid=$post[postid]">Report Post</a> | $post[iplogged]</smallfont></p>

    Comment


    • #3
      I got it, Fury, but notice how I don't have a signature yet the links remain all the way on the bottom. By default, the links would be on the left but also in the middle of a post.

      Can you help? Thanks in advance.

      Comment


      • #4
        That's how they behave here too. It's just that our posts are taller than our user info in the left column. Watch.

        Comment


        • #5
          To get them to stick to the bottom, go back to the postbit template

          A little way up from the line of code containing the report/IP links is this:

          <td bgcolor="$post[backcolor]" width="100%" valign="top">

          Change that to this:

          <td bgcolor="$post[backcolor]" width="100%" valign="top" height="100%">
          <table border="0" cellpadding="0" cellspacing="0" width="100%" height="100%"><tr><td height="100%" valign="top">

          And JUST BEFORE the line with the report/IP links, add:

          </smallfont></td></tr>
          <tr><td><smallfont>

          Then after the report/IP link line, change the

          </td>

          to:

          </smallfont></td></tr></table>
          </td>




          That whole section should then look about like this:

          <td bgcolor="$post[backcolor]" width="100%" valign="top" height="100%">
          <table border="0" cellpadding="0" cellspacing="0" width="100%" height="100%"><tr><td height="100%" valign="top">
          <smallfont>$post[icon] <b>$post[title]</b></smallfont>
          <p><normalfont>$post[message]</normalfont></p>
          $post[attachment]
          <p>$post[signature]</p>
          <p>$post[editedby]</p>
          </smallfont></td></tr>
          <tr><td><smallfont>
          <p align="right"><smallfont><a href="report.php?s=$session[sessionhash]&postid=$post[postid]">Report this post to a moderator</a> | $post[iplogged]</smallfont></p>
          </smallfont></td></tr></table>
          </td>

          Comment


          • #6
            Ah,ok. Thanks for clarifying that for me, Fury.

            Comment


            • #7
              No problem

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X