Announcement

Collapse
No announcement yet.

vb:raw variables in SHOWTHREAD quick vb4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vb:raw variables in SHOWTHREAD quick vb4

    Hello:

    I'm very new to modifying vb temples and am not sure if this a mod the previous sysop did or if it's out of the box... but have a programming background. With the last update to vb4.2.3 our users started complain that the Manage Attachment button in the Quick Reply section is no longer working. A new window pops up but instead of the image up users are shown a message about not having permissions to access this page. As admin I've tested this out and get the same message. Looking at our template page there are some raw variables poststarttime, posthash, and contenttypeid that are not being parsed to create the URL. If users click the advanced reply and use that Manage Attachments everything works fine. Wondering if the variables are out of the loop. I was trying to get a list of all raw variables on a test page but couldn't find a var_dump equivalent in the VB code.

    Thank you in advance for your support.

  • #2
    In the template list does the template show as edited? It would be either red or orange in the list if it is edited. If it is edited, revert the template. What may have worked in previous versions may not work now.

    There is no var_dump() equivalent in vBulletin 4 that I am aware of. You would have to edit the corresponding file for the page that you're viewing and hardcode it for any debugging.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Hi Wayne:

      Did this and then tried putting back in {vb:raw posthash} at the top just to see if it's able to pull in this variable. It was not.

      Thanks

      Comment


      • #4
        So you've determined that the problem is posthash and other variables aren't set? I think that is a mod since the Attachment Manager button doesn't seem to appear in the quick reply by default.
        Which template are you putting {vb:raw posthash} in?

        Comment


        • #5
          hi kh99

          ​Yes "Manage Attachments" was a template mod on SHOWTHREAD which used the values. Prior to the last upgrade {raw vbosthash} . The odd thing is that when I enable quick reply VB -> Options -> Message Posting and Editing Option and check the source code on the render pages I see that the vB_Editor_QR has posthash and other codes embedded in it... then further down in the hidden variables I see posthash but no values. I have Yes, No Click for quick reply.

          Thanks

          Dave

          Comment


          • #6
            There are different templates in a page and different variables available to each template.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              Originally posted by dmiyares View Post
              hi kh99

              ​Yes "Manage Attachments" was a template mod on SHOWTHREAD which used the values. Prior to the last upgrade {raw vbosthash} . The odd thing is that when I enable quick reply VB -> Options -> Message Posting and Editing Option and check the source code on the render pages I see that the vB_Editor_QR has posthash and other codes embedded in it... then further down in the hidden variables I see posthash but no values. I have Yes, No Click for quick reply.

              Thanks

              Dave

              To be honest I'm not sure I follow all that. And I'm not sure that quick reply needs a posthash since you're making a new post and not editing one. Edit: ...but now I remember, missing posthash is one of the things that makes the attachment manager button result in a "no permission" message.

              Anyway, you can set General Settings > Add Template Name in HTML Comments to Yes, and you'll get html comments in the rendered page that tell you what template different parts came from.
              Did you update your php version when you upgraded? Just a guess, it could be that that there's a plugin that's part of that mod, and maybe now it doesn't work because of the php version? Actually it seems unlikely, but you could check your php error logs for a message.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X