Announcement

Collapse
No announcement yet.

[VB5] strange behavior after translation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [VB5] strange behavior after translation

    Friends, I am with version 5.1.2 PL3 and I began to translate the phrases for Portuguese.

    My procedure: AdminCP >> languages ​​& phrases>> Language Manager >> Edit / Translate InglÍs (us) Phrases.
    in "phrase type", I started por "navbar links "

    however, after translating the phrases, one of the phrases (SIGN UP), besides not being translated now is presented as "navbar_sign_up" (image below).

    Click image for larger version

Name:	FC.jpg
Views:	4
Size:	22.5 KB
ID:	4136754

    the link continues for the registration form. it is very good.
    but I can not translate the sentence, because the field no longer appears in "phrase type" >> "navbar links" (image below).

    Click image for larger version

Name:	FC2.jpg
Views:	8
Size:	44.6 KB
ID:	4136755

    I can not even find the phrase "navbar_sign_up" in the search in phrases.

    can please give me any tips on how to solve this problem? is there any file that can perform the upload to fix the problem?

    Thank you!



    Attached Files

  • #2
    What is your memory limit, and max_execution_time in php? Also, what version of vBulletin are you running?

    Comment


    • #3
      thanks for reply!

      the memory_limit is set to 32mb, and the max_execution_time is set to 0.

      version VB 5.1.2 PL3

      Luiz







      Last edited by -=|zami|=-; Thu 4th Sep '14, 12:55pm.

      Comment


      • #4
        friends, in addition, i tried use the site builder, but without success:
        1) I tried to insert a new navigation item, but stayed eternally "working" without saving.
        2) I tried renaming "navbar_sign_up", but also stayed eternally "working" without saving.

        THX!

        Comment


        • #5
          Update the memory limit to 64 MB, Set the max execution time to 60 seconds. Delete the link from the navbar and re-add it.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment


          • #6
            You should also create a new language and not override the default English with your translations. The default English will be necessary if you ever need support.

            Comment


            • #7
              Friends, thanks for the help!

              Originally posted by Wayne Luke View Post
              Update the memory limit to 64 MB, Set the max execution time to 60 seconds. Delete the link from the navbar and re-add it.
              I made the adjustment suggested.


              Originally posted by Joe D. View Post
              You should also create a new language and not override the default English with your translations. The default English will be necessary if you ever need support.
              but first, I must restore to the original language package (English (US)), correct? any tips that how can I do this?

              only "AdminCP >> languages ​​& phrases >> download / upload languages>>Import ​​Language XML File >> EITHER upload the XML file from your computer >> Overwrite Language >> English (US)" is enough for this?

              Comment


              • #8
                ...If the translated phrases are already saved I do not believe overwriting the language with the master language will undo it, but you can try.

                How many phrases have you translated already? The only way to erase them all at once would be directly in the database which isn't something officially supported.
                Last edited by Joe D.; Sat 6th Sep '14, 2:30am.

                Comment


                • #9
                  Hello!

                  I made the adjustments, but without success. the system responds: "Error saving the navigation bar configuration Please try again.."

                  overwrite the language, really, did not work.

                  many phrases are translated, it is a package from VB3

                  some other tip?

                  Thank you!

                  Comment


                  • #10
                    Installing a VB3 language on VB5 breaks the system. Only VB5 languages should be installed on VB5.

                    First make a database backup.

                    Then run this query-

                    Code:
                    DELETE
                    FROM phrase AS p1
                    USING phrase AS p1
                    LEFT JOIN phrase AS p2 ON ( p1.varname = p2.varname
                    AND p2.languageid = -1 )
                    WHERE p1.languageid =0
                    AND p2.languageid IS NOT NULL;
                    [I]And then use the option to Rebuild All Languagses.

                    And see if that clears out all the problem phrases.

                    Comment


                    • #11
                      Hello!

                      command unfortunately did not work:

                      "# 1064 - You have an error in your SQL syntax; check the manual que Corresponds to your MySQL server version for the right syntax to use near 'AS p1
                      USING THE phrase p1
                      LEFT JOIN phrase AS p2 ON (p1.varname p2 = 'at line 2 "

                      my version of mysql is 5.5.37-cll

                      I updated the version of VB, but the package was not reinstalled and the phrases translated remained.
                      I also tried to install the language pack in English directly by the AdminCP, but the system has identified the package as "master language" and only updates the existing package without installing the language pack in English.

                      is there any way to reinstall the language pack in english?

                      Thank you for your help!

                      Comment


                      • #12
                        Reinstalling the language file won't help.

                        Does your VB database use table prefixes? If you look at the tables in the database, do they all start with the same thing? Like vb_access, vb_thead, vb_post?

                        Comment


                        • #13
                          ok, thank you!

                          yes, I use prefix: forum. and I have added before the name of the phrase table

                          DELETE FROM forumphrase AS p1 USING fourmphrase AS p1 LEFT JOIN forumphrase AS p2 ON ( p1.varname = p2.varname AND p2.languageid = -1 ) WHERE p1.languageid =0 AND p2.languageid IS NOT NULL;

                          with or without prefix. has the same error.

                          thank you!

                          Comment


                          • #14
                            Make a database backup.

                            Next- Truncate your phrase table. (For you its forumphrase)

                            Finally re-run the upgrade.php script. you'll need to re-upload the original /core/install/ folder that came with your current 5.1.2 version and run the upgrade.php in that.

                            Running the upgrade script will re-import your master language. If you prefer not to run the upgrade this can also be done via tools.php if you know how to use that.

                            Comment


                            • #15
                              thank you all!

                              the package of the English language is installed, although there were some problems:
                              1) occured the same problem that I reported on "navbar_sign_up" with the link "activity stream". only in English, in place of "activity stream" appeared "navbar_ativity_stream". but the Portuguese translation remained. I found this translation and have modified to "activity stream". was ok!
                              2) amazing, but a few phrases in Portuguese remained. but I'll try to change them manually. should also clear the "phrasetype" table?
                              3) the problem "navbar_sign_up" was solved according to the suggestion of Wayne. But the link appears for all users, including those who are already logged. should not only appear to those who are not yet logged in?

                              thanks!!!

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X