Announcement

Collapse
No announcement yet.

Subnav Bar Out of Position After Upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Joe D.
    replied
    IIRC in the past the unit being missing wasn't a big deal but it was still a mistake. The upgrade didn't remove the values but the new template required the values to work correctly. Glad it is sorted.

    Leave a comment:


  • napy8gen
    replied
    I think because last version before you upgrade do not have these stylevars.

    Leave a comment:


  • dh001
    replied
    Bingo!

    Both navbar_menu_height and popupmenu_height were missing a units value (empty). After specifying the units everything is back to normal.

    Thanks much!

    I don't know for sure if the unit values were removed during the upgrade, but I suspect that was the case. A possible bug?

    Leave a comment:


  • Lynne
    replied
    Check all your customized stylevars that you listed and make sure if they have a "Units" dropdown, that it is NOT empty.

    Leave a comment:


  • dh001
    replied
    Everything was working normally with the default style. I only switched to the default style after noticing the navbar had dissapeared to see if the problem was with the changed style, which it is apparently.

    I'm not using the default style but the modified style is very close to the default. No stylevars were changed after the upgrade and were working properly with our previous install (vB 4.0.1).

    The only modified stylevars for the changed style (one in the screenshots) are:

    Global
    -border_radius
    -shadow_color

    ImagePaths
    -favicon
    -titleimage

    NavBar
    -navbar_menu_height
    -navbar_popupmenu_link_hover_background
    -navbar_popupmenu_link_hover_color
    -navbar_tab_bevel
    -navbar_tab_size

    Notices
    -notices_background
    -notices_shadow_color

    PopupMenus
    -popupmenu_height

    vbcms
    -vbcms_header_borderBottom
    -vbcms_header_borderTop
    -vbcms_header_font
    -vbcms_header_margin
    -vbcms_widget_header_padding
    -vbcms_widget_margin

    I double checked all of these values and none of them seem to be out of the expected ranges.

    Leave a comment:


  • napy8gen
    replied
    I have seen this problem but this was long ago, so I cannot remember exactly but I think it caused by stylevar values.. Since you are using default style, I advices that you revert all your stylevars from your style manager> default style name> from the drop down menu find "revert all stylevars"

    Leave a comment:


  • Joe D.
    replied
    Hello- You said you tried the default style and the page rendered normal- does that mean everything worked with the default style? Because your screenshots look pretty close to default now?

    If it is NOT working with the default style try disabling hooks and see if you still have the issue- http://www.vbulletin.com/forum/forum...ystem-globally

    Leave a comment:


  • dh001
    replied
    Also, there is a problem with Opera 12.17 x64 when trying to post a topic (hence the 3 additional re-posts). It was trying to get me to download a file and would never complete? Please keep this post since there were some errors in the others.

    Leave a comment:


  • dh001
    started a topic [vB4] Subnav Bar Out of Position After Upgrade

    Subnav Bar Out of Position After Upgrade

    After upgrading to vB 4.2.2 yesterday the subnav bar has disappeared and the text appears to underlay/overlay other page elements. When the subnav menu links are expanded there is also a bunch of padding around them. I tried a default style and the page rendered as normal. Before the upgrade, everything was working normally. I looked through the navbar templates from this style but didn't know what to do to resolve this or even if the problem lies in the navbar templates.

    I thought this may be linked to the Tabs vbSoporte plug-in we are using but it still happens when the plug-in is disabled.

    Any assistance would be appreciated.

    Click image for larger version

Name:	subnav-links-misplaced.JPG
Views:	13
Size:	54.2 KB
ID:	4128516
    Subnav bar links ovelaying calendar header.

    Click image for larger version

Name:	subnav-links-misplaced2.JPG
Views:	8
Size:	76.0 KB
ID:	4128520Missing subnav bar. I suspect is is hiding behind the forum container.

    Click image for larger version

Name:	subnav-menu-padding.JPG
Views:	12
Size:	104.2 KB
ID:	4128518
    After clicking to expand the subnav menus there is too much padding between the different options.
    Attached Files
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X