Announcement

Collapse
No announcement yet.

[VB5] User selecting style issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [VB5] User selecting style issue

    Basically, i want to disable the default theme option completely. I am considering deleting it.

    I want only my custom theme to be the default and that is it.

    I am still seeing the dropdown box in the bottom left showing the theme options after doing the following.

    I have my custom theme set as default.

    I have turned off "Allow users to change styles" in Settings >> Styles and Language options.

    I have set both themes to not be allowed for selection by users.

    Any input is much appreciated.

  • #2
    You, the admin, will always see all the styles in the dropdown. Regular users should not see the other styles, however there is a bug in the current version of vB5 which allows all users to see all styles right now.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      That must be the issue. I have version 5.0.5 and have created numerous standard user accounts. When do you presume this will be fixed?

      Comment


      • #4
        Here's a dirty fix for now.
        (If you ever decide to enable styles, you'll need to remove this manually)

        Open the template css_additional.css
        Add the following code at the bottom (or anywhere if it's empty)
        Code:
        .stylechooser
        {
          display:none;
        }
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Interesting, i did that but still see it there. Very odd..

          Comment


          • #6
            Probably a cached view.

            AdminCP > Maintenance > Clear System Cache
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.4 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              I tried that as well What happens if i just delete the default style from the AdminCP > Style Manager

              Comment


              • #8
                Originally posted by superwow View Post
                I tried that as well What happens if i just delete the default style from the AdminCP > Style Manager
                Wouldn't hurt but shouldn't be necessary...it's useful to have a default style available for testing.

                Try this instead:
                Code:
                .stylechooser
                {
                  display:none !important;
                }
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.5.4 Demo
                AdminAmmo - My Cloud Demo

                Comment


                • #9
                  Still the same. Very strange. I even changed browsers and cleared their cache as well.

                  Comment


                  • #10
                    Odd.

                    Can you please send in a support ticket, with admincp credentials in the "Sensitive Data" field.
                    I'm sure we can make this not show somehow.
                    Please put a link to this thread also.

                    To raise a support ticket please go here: http://www.vbulletin.com/go/techsupport
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.5.4 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #11
                      Originally posted by Mark.B View Post
                      Here's a dirty fix for now.
                      (If you ever decide to enable styles, you'll need to remove this manually)

                      Open the template css_additional.css
                      Add the following code at the bottom (or anywhere if it's empty)
                      Code:
                      .stylechooser
                      {
                      display:none;
                      }

                      This worked for me at 5.1.0 Beta 2

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X