Announcement

Collapse
No announcement yet.

Style reverts to default on visit of "home" page, even if other skin selected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [vB4] Style reverts to default on visit of "home" page, even if other skin selected

    This is an odd bug. The style only reverts if the "home" page is visited, the other sections of the cms are fine, as well as the blogs and forums.

    Any idea why that one page would revert and how I could fix it?

    Thanks.

  • #2
    I cleared the cms cache, and I think that fixed it.

    Comment


    • #3
      you might have to edit your own cms style then set it to be the default style iirc

      Comment


      • #4
        I am having this same issue....

        I want to offer several style options to my members. Upon changing the style all of the forum, blog, CMS pages change accordingly but the main page still refers to the default style.

        In the front page editor the style is selected to "inherit" I have tried to move it to board defaults but when I click apply it goes back to inherit..

        anyone having this issue?


        FYI, I am running this on a test site... so my current link is still using vb 3.8

        Comment


        • #5
          In the frontpage section editor. select the style, don't put inherit. see what happen.
          Get Our New Flat Theme Pro Pack or Grab all 34 vb5.5.4 skins @sultantheme.com -vb3 responsive style or vb4 responsive style and vbcloud custom style

          Comment


          • #6
            Gonna try that and see if it will work. Still doesn't fix my issue cause I want my styles to be selectable by the members.

            Comment


            • #7
              Try resetting your cms cache in Vbulletin CMS>Reset Cache, that may make the front page stop changing skins. You should do this every time you make a change to your cms.

              Comment


              • #8
                I have been resetting my Cashe quite regular while working on the site... still doesnt help..

                For some reason, when I try to set the style to " Board default" and click apply it always reverts back to "inherit"

                If I set the default style as a custom color that I created it will work. The front page will take that color. Then when you go down to the custom color selector and change the style as a member would do. It will apply this style to the forum and all the other pages except the CMS main page. It doesnt change.

                There has to be some sort of fix where the CMS main page will follow the style of the entire site, and let my users to select which one they prefer.

                Comment


                • #9
                  This was happening to me. I figured out that it was my setting labeled default mobile style. Once I set that back to none this issue was resolved. It was hard to figure out at first. I'm not the only forum admin browsing with a smart phone.

                  Comment


                  • #10
                    I was looking through my usercp last night, and for whatever reason my default skin was set to something different than what I use normally. I wonder if that's what the conflict was?

                    Comment


                    • #11
                      That could be the problem. It depends on what you have set for the Style for the Home Section (inherit, board default, or a specific style).

                      Please don't PM or VM me for support - I only help out in the threads.
                      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                      Want help modifying your vbulletin forum? Head on over to vbulletin.org
                      If I post CSS and you don't know where it goes, throw it into the additional.css template.

                      W3Schools <- awesome site for html/css help

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X