Announcement

Collapse
No announcement yet.

[howto] -> Spaces Between Categories

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    I bet my template hack works 100% if you have no code-hacks applied It is obvious some things have changed in your other templates. Which I have not done myself, so .. can't really give support on that.

    Comment


    • #32
      I found the problem and mine is fixed now....Airwaves...I can help you...if you moved your "loggedinusers" to the top then that is the issue and you have to do this in addition:

      In forumhome template find this:
      Code:
      <tr align="center">
        <td bgcolor="{tableheadbgcolor}"><smallfont>&nbsp;</smallfont></td>
        <td bgcolor="{tableheadbgcolor}" width="80%" align="left"><smallfont color="{tableheadtextcolor}"><b>Forum</b></smallfont></td>
        <td bgcolor="{tableheadbgcolor}"><smallfont color="{tableheadtextcolor}"><b>Posts</b></smallfont></td>
        <td bgcolor="{tableheadbgcolor}"><smallfont color="{tableheadtextcolor}"><b>Threads</b></smallfont></td>
        <td bgcolor="{tableheadbgcolor}" nowrap><smallfont color="{tableheadtextcolor}"><b>Last Post</b></smallfont></td>
        <td bgcolor="{tableheadbgcolor}" width="20%"><smallfont color="{tableheadtextcolor}"><b>Moderator</b></smallfont></td>
      </tr>

      remove it from this template and place it in the
      forumhome_forumbit_level1_nopost template at the end of the template after this line:
      Code:
      	<br><smallfont color="{categoryfontcolor}">$forum[description]</smallfont></td>
      </tr>
      Last edited by Dark_Wizard; Sat 2nd Feb '02, 4:04am.

      Comment


      • #33
        Thank you Dark_Wizard

        Hey Dark_Wizard,

        Thank you, very kind of you to make an effort! I hope it works now, for those who altered templates/php already..

        Comment


        • #34
          done it now and they are separated, except that now i have a strange line going across...

          its attached and zipped

          a 256colour bmp

          Comment


          • #35
            Read back

            Originally posted by Airwaves
            done it now and they are separated, except that now i have a strange line going across...

            its attached and zipped

            a 256colour bmp
            More info about that white line is in this thread.

            Comment


            • #36
              Hey! I put this template hack in, and it put the spaces in correctly, but really screwed up the centering of the boards. I am going to leave it like this for now, but could someone take a look and see what I did wrong?

              Talon

              Comment


              • #37
                Originally posted by Talon3DHQ
                Hey! I put this template hack in, and it put the spaces in correctly, but really screwed up the centering of the boards. I am going to leave it like this for now, but could someone take a look and see what I did wrong?

                Talon
                i see nothing wrong with it? this the board you talking about? http://www.3dhq.net/forums/index.php

                btw i like how you got the catagories on top of the forums. could you tell me what you did?

                Comment


                • #38
                  Originally posted by ~Recluse~


                  i see nothing wrong with it? this the board you talking about? http://www.3dhq.net/forums/index.php

                  btw i like how you got the catagories on top of the forums. could you tell me what you did?
                  On the frontpage of the forum (the index of the categories) each category now has its own indexing header.

                  The one that says: Forum / Posts / Threads / Moderator(s) is now below every category

                  The next step is to split up the categories from eachother so they really look like they are seperate boards. But how it looks now, is pretty cool too

                  Credits goto Smoothie from macfora.com who provided me with the right code!

                  Open your forumhome template.
                  Look for:

                  Code:
                  <tr align="center">
                    <td bgcolor="{tableheadbgcolor}"><smallfont>&nbsp;</smallfont></td>
                    <td bgcolor="{tableheadbgcolor}" width="80%" align="left"><smallfont color="{tableheadtextcolor}"><b>Forum</b></smallfont></td>
                    <td bgcolor="{tableheadbgcolor}"><smallfont color="{tableheadtextcolor}"><b>Posts</b></smallfont></td>
                    <td bgcolor="{tableheadbgcolor}"><smallfont color="{tableheadtextcolor}"><b>Threads</b></smallfont></td>
                    <td bgcolor="{tableheadbgcolor}" nowrap><smallfont color="{tableheadtextcolor}"><b>Last Post</b></smallfont></td>
                    <td bgcolor="{tableheadbgcolor}" width="20%"><smallfont color="{tableheadtextcolor}"><b>Moderator</b></smallfont></td>
                  </tr>
                  Cut that code and 'save' the template.

                  Now open the forumhome_forumbit_level1_nopost template.
                  Paste the code you cut from the other template below the last line of what
                  is currently there.
                  Save it
                  Now do the same for the forumhome_forumbit_level2_nopost template.
                  Save it.
                  And thats it. All done.

                  Sweet!
                  ----------- from my own backup log :P

                  Comment


                  • #39
                    OK, I put the template mods back in, so everyone can see the problem I am having. Something changed the width sizes of the Forum Title, Last post by, etc, and they are not all even in the categories anymore, and changed depending upon how long the Last Posters's name is. Also, I have the Line at the top between the Currently Online and the Beginning of the first category.
                    The forum is here:

                    http://www.3dhq.net/forums/index.php

                    Comment


                    • #40
                      ok, went through this thread again, and found the fix for the extra table (Thanks Asfprez!)

                      Talon

                      UPDATE

                      I also did what Dark_Wizard said to do, regarding the colum widths, but that did not work. They are still off.
                      Last edited by Talon3DHQ; Fri 8th Feb '02, 8:44am.

                      Comment


                      • #41
                        Ok,I attached the image so you would know what I am talking about. The colum widths keep changing in each category depending on the length of the name of the last poster. Any suggestions on how to make them all one size and stay there?

                        Comment


                        • #42
                          I experience that so I removed this hack until a better method is devised.

                          Comment


                          • #43
                            Well, I don't know how, but I took care of it for the most part. I managed to get the "off-centerness" to be on just on the on colum where the last post info is on the right side of the table, so at least it doesn't look as bad.

                            Comment


                            • #44
                              thanks xiphoid, worked like a charm

                              Comment


                              • #45
                                Yes i am also experiancing the problem of the colums not lining up correctly. I have also removed it untill it can be fixed. Or untill some can explain it. Thanks

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X