Announcement

Collapse
No announcement yet.

How to take Vbulletin out of table

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to take Vbulletin out of table

    I try to customize a vbulletin template by doing 2 basic changes, inserting a header and footer.

    The problem is that both the header and footer appear inside a table instead of taking the whole page or browser. It seems its insertin them inside a table that contains the forum and not not outside.

    My question is where is that table in the skin? I cannot find it. Im not sure if i have to take all the content outside this table and then put a header and footer or if there is a way the header and footer appears correctly on the top and foot.

  • #2
    spacer_open and spacer_closed are like the wrapper templates.

    Comment


    • #3
      Im not sure what you mean. When I go to edit the template I have 3 files:
      header, headinclude and footer

      Comment


      • #4
        Originally posted by nibb View Post
        Im not sure what you mean. When I go to edit the template I have 3 files:
        header, headinclude and footer
        No, I am saying the whole board is enclosed in a wrapper. The code for this wrapper can be found in the templates spacer_close and spacer_open.

        Comment


        • #5
          I tried deleting those codes and still the header and botton dont appear to fit wide and height. The header should go before the <head> tags.

          Where is the first HTML line that vbulleting generates on a style?

          It seems each time i paste the customization in the header or headinclude the output shows HTML before those. If I find where the head tags are generated it would fix it but not sure if that will change it site wide or just for this template.

          Comment


          • #6
            I dont know what happened but this just killed my site. The headerinclude became blank and now the whole forum is messed up. The worst of all is that I copied the main style to do this and for my surprise the main style is also broked and another style i had for a category is also broken. The changed just merged to each single style i had in vbulletin, this is exactly what i did not wanted and why i copied, downloaded renamed and uploaded a test style. But now this test style messed the others as well.

            Comment


            • #7
              If you were careful, you created a backup of your database before you started changing the Forum. If not you should learn to do that before making such changes or make them in a test forum first.

              If you made a backup before your started, you can restore the backup and your Forum will be as it was before you started the changes.

              Otherwise you may need to restore your most recent backup and it will put back what you changed, but you will lose whatever was added to the database between the backup and now.

              One other possiblilty is you might create a new "default style" and then copy the the parts of the default which you have deleted back into your current style.

              Good luck.

              Regards,
              Slappy

              Comment


              • #8
                Yes I have backups, but restoring the whole forum just because of a style change doesnt make sense. I have used allot of software and never saw something so crap at making a style. I specially created a copy of the style so I wast not editing the main one i dont know why the hell vbulleting just deleted the whole code on all 3 styles. Where does this make the changes on on a file or a database?

                Comment


                • #9
                  vBulletin does not do what you think you did. If you are in the AdminCP and you edit one particular style, it doesn't change the others. You have to have done something "extra" to whatever you uploaded to make it overwrite more than you thought you were going to overwrite.

                  This is one of the principle reasons why you should set up a test forum and why you should create a backup BEFORE you edit. For example, you have the ability to download a particular style and save it on your local machine and if you screw up that same style on the Production Forum, you can "import" the "original" style back in through the AdminCP to fix what you did.

                  Something in what you created or clicked has caused the problem.

                  Are you editing in the AdminCP? Or on a test forum? If on a test forum, how and what did you import to your production forum?

                  Regards,
                  Slappy

                  Comment


                  • #10
                    Originally posted by nibb View Post
                    I tried deleting those codes and still the header and botton dont appear to fit wide and height. The header should go before the <head> tags.

                    Where is the first HTML line that vbulleting generates on a style?

                    It seems each time i paste the customization in the header or headinclude the output shows HTML before those. If I find where the head tags are generated it would fix it but not sure if that will change it site wide or just for this template.
                    The page header goes in the body tags, not head tags. And then changes you did should only have applied to one style. You should be able to revert your templates or create a new style.

                    Comment


                    • #11
                      Thats what I did. This is HUGE bug in Vbulletin.

                      I had 2 styles. The default customized in colors and other stuff. And a second I downloaded from the internet totally different to the default.

                      What I did was:

                      Downloaded to my PC the default style. Rename and uploaded to again with another name. So i basically created a 3 third style based on the default for testing.

                      Now when I was testing my changed vbulletin suddently saved the headinclude part on this style with nothing, that means blank. It replicated the change to the other 2 styles. Now on each style when you load "headinclude" it shows blank and next to instead of the normal revert button it says it was customized on a primary style and if you clic it it says "undefined"

                      I tried uploaded the original copied style i had and nothing. Still the part where the code for "headinclude" should show it shows blank. Since I did not changed anything on it actually can someone be so kind and post the default content that comes there so i can paste it again and see if that works.

                      This really sucks. I will probably shut down the forum and go back to SMF since this broke the work of months, the other 2 styles took the change without me saving it to those. I dont understand why the editing of 1 style just saved it to the others without my permission.

                      Comment


                      • #12
                        I forgot I had another site with vbulletin so i logged and copied the code in headinclude to this forum and all styles show correct again.

                        Can someone please tell me now how can i safely edit a style so this doesnt happen again? I use Opera browser and I think something caused vbulletin without my permission to save the changed in all style. I want to created a totally different style that doesnt have to do anything or ist not even related to the main one.

                        Comment


                        • #13
                          You are, of course entitled to do whatever you wish, but there is no default process which would cause the style manager to save changes to more than one properly created style.

                          It does not seem possible, unless something glitched on your server that you could be editing one particular style and it would save the changes to three different styles. I've made changes many times to the templates of our forum and, although the changes were not significant, I have never had the changes I made in one style save in some other style, let alone all existing styles.

                          Again, you can restore your most recent backup and have your own style reinstalled, but lose the posts and threads from the time of the backup to now. That is your choice.

                          Something in the downloading and uploading and/or in the editing process when very wrong, but I have not heard of such an even happening before. That is no guarantee it hasn't happened, because I don't always read all of the posts, but you can be reasonably sure that if it happened the way you describe it, it should have happened to someone else. Maybe a search will confirm when it has been reported before.

                          Regards,
                          Slappy

                          Comment


                          • #14
                            Well it did. When I edit the style it says something about linking to a primary style. Im not sure what that means but this must be the error. It modifies the style and linked styles with it. I just dont know what it means because this is the default style. Also now in headinclude box appears a revert changes box, but when i use it, it reverts to blank.

                            Comment


                            • #15
                              Glad you got your style back. Again, I don't believe there is a "process" in vBulletin which will cause this problem to copy one style into another. I'm not sure how a browser glitch could cause the problem.

                              Here's one possiblity you might try. There are program like XAMMP and WAMP, which you can download off the internet and install on your local Windows machine and have a running "server" with Apache, MySQL, and PHP running on which you could then copy a "local" copy of vBulletin and use it for testing and style editing purposes. You essentially just click and install and then set up the forum in the correct folder on your local machine, adjust the config.php file as directed.

                              Then you download a copy of your database, prefferably using SSH Shell, and "restore" it to your local database and you have a local running copy of your forum to play with. As long as it's not open to the internet, it does not violate your license and you can make modification to your heart's content without risk to your production forum.

                              When you have finished, you can save style edits and import them into your production forum, but it is ALWAYS a good idea to make a MySQL backup before making any major modification of your production forum.

                              [EDIT] Yes, if both your styles were the default, it is possible that "Merge into Style" portion of the Import facility caused your problem if you had not properly renamed the styles and it though they were all the "default."

                              Regards,
                              Slappy

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X