Announcement

Collapse
No announcement yet.

VB style designed for 3.5.4 , small layout problem on 3.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • VB style designed for 3.5.4 , small layout problem on 3.6

    Hi,

    I designed a style back when 3.5.4 was the latest version. There is a small problem with it when exported to version 3.6. When viewing threads (showthread.php) the posts are wider than the width of the page.

    you can an example here:

    http://img74.imageshack.us/img74/6489/vbproblempv0.gif

    The width of the forum is 800 pixels while the posts are 850 px wide (750+ a padding of 50px on each side)

    i looked in the source code and there is a duplicate piece of code before each post :
    ---------------------------------------------------------

    Code:
    <div id="posts"><!-- post #5083 -->
    
        <!-- open content container -->
    
    <div align="center">
        <div class="page" style="width:800px; text-align:right">
    
    <div style="padding:0px 25px 0px 25px">
    
        <div id="edit5083" style="padding:0px 0px 6px 0px">
        <!-- this is not the last post shown on the page -->    
    
    
    <!-- post #5083 -->
    
        <!-- open content container -->
    
    <div align="center">
        <div class="page" style="width:800px; text-align:right">
    <div style="padding:0px 25px 0px 25px">
    
        <div id="edit5083" style="padding:0px 0px 6px 0px">
    
        <!-- this is not the last post shown on the page -->
    -------------------------------------------------------------------------------

    so before each post this code appears twice instead of once and adds unnecessary 25 pixels of padding on each side.

    i searched for "<!-- open content container -->" in styles manager and it seems this code originates from 'spacer open', yet the code there is very short and doesnt seem the be the cause of this problem.

    i looked at showthread.php but its a little too much for my current programing skills...

    would very much appreciate any help here since this little thing is preventing me from upgrading the forum to the version 3.6.

  • #2
    That extra 25px on each side is coming from the double containers. Unfortunately I can't tell you how to fix it since my templates are far from stock now, and I've completely gotten rid of any traces of the "containers."

    My guess is that you have $container_open (or whatever the code is) twice in your postbit and wherever else you have the problem. Getting rid of the second instance should remedy your problem. I doubt the problem is in showthread.php.

    Good luck with your search.

    Comment


    • #3
      Were you ever able to figure out the problem? I am experiencing the same issue on my forums after upgrading to 3.6.1.

      Comment


      • #4
        Open up the template SHOWTHREAD - It should be in there. You may have to remove a code that says spacer_open or something of the sort

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X