Announcement

Collapse
No announcement yet.

Need UTF-8 Languages for 3.8.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need UTF-8 Languages for 3.8.6

    Hello i need the following languages in UTF-8 can someone help me please?

    French
    German
    Russian
    Polish

  • #2
    the thing would be to require a complete rebuilding of the language system to become UTF8 entirely... that would clear out a lot of things...
    oh no, i'm not going with Xenforo... come on, i'm better than that... i stick with Wordpress... rofl

    Comment


    • #3
      So whats to do in my situation?

      At time i use the 3.8.6 English UTF language file...
      But lots of users wish the other languages listed above.
      But i found only the english...

      Comment


      • #4
        You can convert it yourself. Open the XML file up in a text editor which supports different character encodings (surprisingly, even notepad does the trick now for me in Vista), change the header to say UTF-8 instead of ISO-8859-1 (or whatever their native encoding is), and set the html charset to UTF-8, then go File > Save As, set the encoding to be Unicode UTF-8 (if available, choose to NOT include BOM/Byte Order Marking), and you're good to go.
        Best Regards,
        Andy Huang

        Comment


        • #5
          Hey I have the same problem, and a few more ;D

          First, I've downloaded my installed russian language (in windows-1251 from ACP). Then I made the suggested steps above (edit with texteditor), reimported the russian language (now UTF-8 via ACP) and then I get this error:

          Code:
          XML Error: not well-formed (invalid token) at Line 22
          Then I try to import the original russian language (in windows-1251 format) then I get the same error as above.
          The russian language in forum is now only question marks or totally strange letters. Also, all my hundreds of custom russian phrases of self made pages are gone and appears in english now.


          In this forum, someone suggested following, what I did but nothing has changed:

          UPDATE: If u find that all charactors become '???', please follow the steps:
          Open includes/class_xml.php
          Find:
          PHP Code:
          function &parse($encoding = 'ISO-8859-1', $emptydata = true)

          Replace with:
          PHP Code:
          function &parse($encoding = 'UTF-8', $emptydata = true)

          So, how can I get the russian language working again? All russian language packs here in this forum are not working or has been removed by staff. And how can I save a language inclusive my custom phrases?

          Comment


          • #6
            try the folowing..
            undo the changes.. so you are back to native vbulletin..

            I myself do not use russian.. but it cannot be different to any other language files..

            make sure the top of the file looks like this:
            HTML Code:
            <?xml version="1.0" encoding="ISO-8859-1"?>
            <language name="Russian" vbversion="3.6.8" product="vbulletin" type="custom">
             <settings>
              <options><![CDATA[1]]></options>
              <languagecode><![CDATA[ru]]></languagecode>
              <charset><![CDATA[UTF-8]]></charset>
            open your russian file.. in your texteditor.. (like andy said.. must support utf-8 encoding)
            and save the file as utf-8 format..
            in the line: <language ... name="Russian" can be changed to anything you want.. its only the name of the language displayed..

            The important is.. that you actually can see the cyrilic characters after having converted to UTF8.. (restart editor and load the file again)

            be aware.. that after doing that.. all the cyrillic posts in your forum made before that will probably not be readable and converting those is a real pain.. believe me..

            so before doing this in a live environment.. do testing testing testing..

            Luc

            Comment


            • #7
              Originally posted by Luciano View Post

              The important is.. that you actually can see the cyrilic characters after having converted to UTF8.. (restart editor and load the file again)
              I don't know, but I can't get it working I can't see any cyrilic characters in the xml file.

              I've tried several editors, and bye the way with all other languages it worked well, only the russian language file doesn't.

              Could someone please convert these 2 files (vb + blog) into correct UTF-8 format and reupload it somehow for me?

              www.filesnation.com/3rdsoftware/vbulletin/languages/vb368_zCarot_rus.zip

              www.filesnation.com/3rdsoftware/vbulletin/languages/vbblog-v1-0-2-zCarot-ru.zip

              Comment


              • #8
                well if i were you i'd wait till tuesday.. cause new versions are bound to be out.. vbull and blog..

                but.. an editor that works: is SleeK Action Edit ..
                its shareware.. the main site is down.. but you can get it on most shareware sites..

                Luc

                Comment


                • #9
                  Originally posted by Luciano View Post
                  well if i were you i'd wait till tuesday.. cause new versions are bound to be out.. vbull and blog..
                  ... and in UTF-8 format???

                  Comment


                  • #10
                    Use the vCharset Converter. That is better.

                    Comment


                    • #11
                      Is the russian language ready now? still need it in utf-8 format

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X